TechSpot

Iomega Prestige external hard drive stopped working

By ravinrich
Mar 12, 2013
Post New Reply
  1. Hi
    I am using a iomega prestige external hard drive. I have uses this for years with no problem. All of a sudden it as stopped working. It shows up in the listed devices but is inaccessible. It shows up as drive e in the device management. I have assigned another drive letter but with no success. I have removed and reinstalled with no success. It just will not show up in the my computer part. The drive makes no noise and the light does not flash but is receiving power. When I removed the item it did reinstall again no joy. I am now worrying as I have important data on it. My virus scanner also recognises the device and when I run this it finds nothing to scan. Can anyone help?
     
  2. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    Use the Disk Manager to view the partition - - there should be some info if you click on the device. If not, the partition damaged.
     
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,630   +321

    Please clarify for me:
    Do you mean no noise as in no noise? Or does it spin up just doesn't make any bad/unusual noises?

    You removed it.. What do you mean? Did you physically take the hard drive itself out of the enclosure? If so - if you are using a desktop computer, or know someone who is, connect your drive to the desktop computer internally and see what happens.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.