TechSpot

IPConfig Not Working Properly

By ctanne3
Jun 25, 2009
Topic Status:
Not open for further replies.
  1. Hi all,

    I am having trouble gettin ipconfig to work properly. It used to work just find:
    run>cmd>ipconfig and all the right information popped up. Now, when I do the same thing I get a message that says:

    Windows IP Configuration

    An internal error occurred: a device attached to this system is not working

    Please contact Microsoft Support Services for further help.

    Additional Information: Unknown media status code.

    So, I can't find my IP address, but I can still connect to the internet without any trouble...I am of course going to try and get in touch with Microsoft as well, but I have a feeling that will probably be a long time on hold so any help anyone could give would be very much appreciated!
  2. ender

    ender TS Rookie Posts: 99

    It would seem that one of your network interfaces is missing a driver. Go to device manager and disable any devices that have issues. That should fix it.

    Or perhaps you can try ipconfig /all or ipconfig /blah where blah is the network interface you're interested in.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.