TechSpot

Java applets will not load

By kane woodward
Mar 19, 2013
Post New Reply
  1. Ok so the title explains it really , I just tried to run a java powered game named runescape and it gave me the error: click for details thing, my java is up to date and it is enabled on my we browser , I have gone into control panel and checked things out but its still pretty much ...... ****** , you could say.
    I need some help and fast , this is really pissing me of because I have update it twice today to try and fix it but it doesnt work

    p.s I do not have javaFX installed so it cant be a conflicting error
     
  2. kane woodward

    kane woodward TS Rookie Topic Starter

    I have poste this on about 5 different forums with no replies at all , please somebody help me with this
     
  3. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    Hmm; feel your pain - - but - - you give no precise information to allow any analysis of the issue.

    Suggest you run whatever induces the symptom,
    use Run->Eventvwr.msc
    look under the Applications and then under System for Error events which finger Java as the problem.

    Then dbl-click on the event and then the double-documents icon which will copy to your clipboard.

    Come back to this thread and PASTE the results for review.
     
  4. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    Updated typo: Eventvwr.msc
     
  5. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    Also prove java is installed properly:

    run->cmd and then enter java -version

    here's mine:

    C:\Users\Jeff>java -version
    java version "1.7.0_10"
    Java(TM) SE Runtime Environment (build 1.7.0_10-b18)
    Java HotSpot(TM) 64-Bit Server VM (build 23.6-b04, mixed mode)​
     
  6. kane woodward

    kane woodward TS Rookie Topic Starter

    Ok so I done the java version thing and I got

    C:\Users\User>java -version
    java version "1.7.0_17"
    Java(TM) SE Runtime Environment (build 1.7.0_17-b02)
    Java HotSpot(TM) Client VM (build 23.7-b01, mixed mode, sharing)

    when I typed Eventvwr.msc , I clicked application and nothing to do with java came up , just things like media center and windows etc


    Btw thanks for beginning to help me solve this problem
     
  7. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    Fine - - let's verify the controls;

    Control Panel ->Java -> Java Tab
    • ->View
    • There are TWO tabs again; User & System
    • What do you see under both?
    Security Tab
    • [x] enable Java Content in the browser
    • Security level >>Medium(recommended)
    Advanced Tab (this gets lengthy)
    • debug -> [ ] none
    • Java Console -> show
    • Default Java for browsers -> [x] IE is grayed
    • Shortcut -> prompt
    • JNLP file/mime prompt
    • App Install->install if hinted
    • JRE Auto-download ->Always
    • Secure execution -> select all BUT show site cert
    • Mixed code ->enable
    • Advanced Security all BUT SSL2.0 compat
    • Misc [ ] nothing

    Quit the browser, relauch and access http://www.javatester.org/version.html

    What do you see?

    /edit/ sorry, had to reformat for readability /edit/
     
  8. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    Bump for format edit
     
  9. kane woodward

    kane woodward TS Rookie Topic Starter

    Hi

    I changed all of the settings to what u specified (most were the same anyway) I went on the page and the classexception error appeared again (red box saying Error: click for details)
    what next?
     
  10. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

  11. kane woodward

    kane woodward TS Rookie Topic Starter

    Its on each browser , ive tried
    IE
    FireFox
    Chrome
    Safari
    Opera

    It seems to be a problem for all browsers, also
    if I try to open a .java file through the coommand line it says that the path to the java.exe I specified isnt correct when it clearly is. I think somehow when I install it it isnt installing properly perhaps. I have looked into this but have found nothing but answers telling people to run the installer as an administrator which I have tried. I had no luck.
     
     
  12. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    hmm; *.java files are JAVA CODE and you need a JDK environment to compile it.

    Java compiles into *.jar files and you only need a JRE environment.

    This http://www.oracle.com/technetwork/java/index-jsp-141438.html explains that the java plug-in comes with the JRE download and install.

    This http://www.oracle.com/technetwork/java/javase/downloads/index.html has both downloads
    and 99% of us only need the right-hand column JRE download.

    Suggest you UNINSTALL your existing Java (Control -> Add/Remove)
    Download this, and try the java test again.
     
  13. kane woodward

    kane woodward TS Rookie Topic Starter

    I would like to thank you for all your hard work fixing my problem , I uninstalled my java and installed it from the link above and it worked perfectly ! - all applets seem to be working and the java tester worked fine
    thank you
     
  14. kane woodward

    kane woodward TS Rookie Topic Starter

    Update : its not working again , shut my pc down and when I turned it back on the error came back
     
  15. learninmypc

    learninmypc TS Evangelist Posts: 5,310   +238

    If all else has failed, might I suggest just simply waiting till the next java update & hope it solves your problem.
    I had a java problem on my XP several months ago & several people in here helped me to no avail. Finally there was a java update & it updated.
    But now due to the hazards of java, I have it disabled in all browsers. Good luck.
     
  16. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    BTW:

    To compile a java program, the command is:
    javac -g Foo.java​
    To run the program that was create by the above you would use:
    • java foo
    • or
    • java foo some.jar
    A java Applet is downloaded from a website, just like CSS, BMPs and Javascript would be.
     
  17. Lenzy

    Lenzy TS Rookie

    I had this same issue, and discovered that Java had been disabled somehow in my firewall. After enabling all Java components in the firewall, it now loads. Hope this helps someone.
     
  18. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    concerned: the < applet > tag in the webpage would create a natural outbound request for the applet and as all outbound requests are "usually" implicitly allowed, we typically don't need FW modifiactions.

    Can you clarify your Platform / OS / and Firewall that you are working with please?
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.