TechSpot

JDK 6 Installation problem in Ubuntu 10.10

By hussainv1
Dec 16, 2010
Post New Reply
  1. Hi guys,

    I tried installing the JDK 6 on Ubuntu 10.10 lucid linux using the command sudo apt-get install sun-java6-jdk. Everything worked fine until i got a screen to accept the license agreement. I can't move forward from here as there is nothing like radio button or any commands to type like 'Y'to accept the license agreement.It just displays 'OK' at the end of the license agreement text. I have attached the screenshot of my terminal. Please help me fix this.


    Regards
    Hussain

    Attached Files:

    • JDK.png
      JDK.png
      File size:
      85.7 KB
      Views:
      5
  2. Try the "tab" key to move to ok and then "enter"...?

    I assume you actually want the java web browser plugin and JRE - and not the JDK (for developers)? I say this because, you're actually installing the JRE by the looks of it.

    It would help if you gave details of what you're trying to do? If you're after a java browser plugin then just installing the JRE won't be enough. The JRE will be installed as a dependency of sun-java6-plugin anyway - is this what you're trying to install? If not, do following as root

    Code:
    aptitude install sun-java6-plugin
  3. hussainv1

    hussainv1 TS Rookie Topic Starter

    yes thanx for the info..it did worked after pressing 'tab' key. I dint know before as i haven't worked much on non-GUI terminal. :)
    well, i wanted to install JDK and the screen shot was in fact the license agreement of JDK in the terminal which popped up after all the packages got downloaded.


    Regards,
    Hussain
  4. From the screenshot, it would appear that you've installed the JRE in fact.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.