Just installed 11.04 but it defaults to Gnome rather than Unity

By donthaveacow
Jul 23, 2011
Post New Reply
  1. Hey guys, I just installed Ubuntu 11.04 in a virtual box but it has defaulted to Gnome rather than Unity. I've never used Linux before (had to get it for my software paper at uni) so really have no idea what I'm doing. Does anyone know how to fix this?

    Thanks in advance!
  2. Leeky

    Leeky TechSpot Evangelist Posts: 4,378   +98

    You need to enable 3D acceleration on the host in order to run Unity, as it requires 3D acceleration to function. You also need to do a few other things:

    1. Ensure you are running the latest version of Virtualbox (4.1.0.73009-win) is current.
    2. Install Guest additions to your Ubuntu guest. From VM window click Devices > Install Guest Additions > click OK for autorun prompt > enter username password to run as sudo and install.
    3. Install all updates from Update Manager
    4.. Shutdown VM.
    5. Click settings on VM > Display > Extended features: tick box for "Enable 3D Acceleration" and click OK.
    6. Fire up VM and all should be working in Unity.

    Here it is running on my PC.

    [​IMG]
  3. donthaveacow

    donthaveacow Newcomer, in training Topic Starter Posts: 24

    Thanks! Works perfectly :D
  4. Leeky

    Leeky TechSpot Evangelist Posts: 4,378   +98

    Cool, glad it solved your problem. :)
  5. Ultiweap

    Ultiweap TechSpot Enthusiast Posts: 742

    Very interesting the Ubuntu...I think I'll be giving it a try
  6. Leeky

    Leeky TechSpot Evangelist Posts: 4,378   +98

    I have to say I prefer Gnome 3's desktop environment considerably more than Ubuntu's Unity offering.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.