Keyboard error or no keyboard

By tryongliph
Jun 17, 2009
  1. My motherboard, EVGA680i Premium, won't let me go beyond the introductery text when i power it up. it says keyboard error or no keyboard, then it goes on to say insert floppy and press enter. i thought it was some wires messing up so i took the whole machine apart, cleaned it and put it back together but same old problem. i even tried the keyboard on another machine and it worked fine. i thought it could also be the power supply so i bought a new one, still nothing. in any case here are the specs of the machine so you guys know what i'm working with: intel quad core 2.6ghz, 1x2 gig ram 667mhz, 512mb nVidea Graphics card, 250 gig maxtor Hdd, 160 gig maxtor Hdd, 480watts smart power supply 20amps average. Please help.
  2. fimbles

    fimbles TS Evangelist Posts: 1,154   +197

    Is it a usb keyboard? try using a ps2 one, it may help.
  3. tryongliph

    tryongliph TS Rookie Topic Starter Posts: 21

    Yeah, its a USB keyboard. i tried the ps2 keyboard and all i could do was hit enter to respond to the insert floppy message cop it was still saying keyboard error or no keyboard.
  4. fimbles

    fimbles TS Evangelist Posts: 1,154   +197

  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Reset the CMOS. If this is a brand new build this should work. If the keyboard error just appeared on an older system, you may have a hardware failure
  6. tryongliph

    tryongliph TS Rookie Topic Starter Posts: 21

    it works now. there were a number of things i did but i'm not sure which one solved the problem. first i removed my dvd drive from the machine and placed it separately from the machine so that the vibratiuon from the other components don't affect it, then i changed my ram (i have 4 sticks but use 2 at a time) and i also disconnected one hard drive. afterwards i was able to install windows vista. when i was done i just disconnected the dvd drive and reconnected the extra hard drive, presto, though my vga was making some funny noises throughout the night but i'm thinking it's also from the power supply, cos the board has an eight-pin slot as compared to the standard 4pin slot by the processor compartment, crap, wish i could take a pix of it so you guys know what i'm talking about, but the good news is the machine is working now. oh yeah and i'm using a ps2 keyboard instead of a usb.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...