TechSpot

Keyboard(s) detected but won't work

By Jace0207
Jun 14, 2010
  1. I cannot get my keyboard to work when I boot up. I just got a INTEL D915GAG D915PSY LGA SOCKET 775 to replace the same motherboard I had that died. When I boot up the lights on the keyboard flash and then I get the message at the bottom of the screen that says press f2 to enter setup press f12 to boot from network. Pressing the buttons does nothing. There is also a message on the screen that says USB Legacy ....... Detected and Legacy Keyboard .........Detected. I have tried 3 different keyboards; two ps/2 and one usb. None of them work. I removed the battery to reset BIOS but this did nothing. I also removed all hardware except 1 stick of ram and booted as "bare bones" as possible, still no luck. I am completely baffled. Anyone have any ides?
     
  2. raybay

    raybay TS Evangelist Posts: 7,241   +9

    Blow out the socket with canned air such as dust-off?
    You might want to try installing a separated USB PC Card in the first available PC Card slot, and try again...
    There are also PCI cards you can obtain cheaply that will allow the installation of the old keyboard with the round socket and plug... work well.
    Then if they don't work, it may be time to replace the motherboard...
     
  3. Jace0207

    Jace0207 TS Rookie Topic Starter Posts: 32

    tried updating the bios by removing the jumper and having flash drive plugged into USB port. Pretty sure the USB is working since the mouse lights up when plugged into it. When that didn't work I tried burning the .BIO file onto a cd to update that way. No luck though, I followed the directions for both these methods of updating bios step-by-step from the Intel website. Now I am thinking it is a bad mobo even though I just got it.
     
  4. raybay

    raybay TS Evangelist Posts: 7,241   +9

    What BIOS is installed, and which version did you attempt to update...

    A motherboard that has failed can be the cause, but rarely.
     
  5. Jace0207

    Jace0207 TS Rookie Topic Starter Posts: 32

    version 431 is installed i tried to update to version 444. The thing is when I try to update from either the flash drive or cd I just get a blank screen. Once I start the comp up with the bios jumper removed, the computer does nothing. The light on my monitor flashes on and off, the cpu fan turns on, but beyond that ... nothing.
     
  6. Jace0207

    Jace0207 TS Rookie Topic Starter Posts: 32

    Also when I put the bios jumper on pins 2 and 3 which is labeled 'config' the message at the bottom of the screen changes from 'press f2 for setup' and 'press f12 to boot from network' to 'entering setup ...' but it just hangs there.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...