TechSpot

Lag problems

By twostepjake
Apr 21, 2013
Post New Reply
  1. All of the sudden all of my games are having a huge lag problems in all my online games. For instance, Smite, I was able to play highest settings with fraps and netflix running no problem. Now I cant even play the game just by itself on the lowest setting. From the forums ive read some people have said to overclock my gpu and I just do not feel comfortable doing that. My graphics card is all the way updated and I have no clue what to do now. heres my system specs. lemme know what other info you need.
    amdfx 4100
    8gb ram
    geforce gt 440
     
  2. stonarda

    stonarda TS Enthusiast Posts: 180   +17

    When did the change happen? Just before the change, what were all the minor changes you did to your computer such as updating or installing programs, websites visited, etc. :)
     
  3. Gunner87

    Gunner87 TS Member Posts: 29

    Check your cpu and gpu temps. When did you update your gpu drivers? if it is recently then it might be the issue there. If so, try rolling back the drivers and see if that helps.
     
  4. twostepjake

    twostepjake TS Rookie Topic Starter

    Stonarda-It started about 3 or 4 days ago. Nothing out of the ordinary. a few of my games had a patch and the usual web browsing. facebook,youtube,netflix etc.

    Gunner87-After I posted here I thought of that exact same thing. heres the results I got. everything looks good to me but im also not the brightest when it comes to this stuff. my graphics card was updated awhile ago I just checked to see if there was an update or new one.
     

    Attached Files:

  5. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,469   +622

    Can't see GPU temp, and that CPU temp is incorrect - unless you live in the open snow. :p
     
  6. twostepjake

    twostepjake TS Rookie Topic Starter

    Gpu is usually around 43 and thats the cpu temp. ive never really seen it go higher than that.
     
  7. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,469   +622

    What's the temperature of your house is Celcius? That says the CPU is sitting on 15C, max of 28C.
     
  8. Gunner87

    Gunner87 TS Member Posts: 29

    Assuming your temps are fine,, you also mentioned that some of the games you played had a patch you applied to them,, That might be an issue sometimes as some patches make the game run worse on some systems.

    Long shot but also a fragmented HDD can sudden lag spikes, though not constant.

    Try running games with other tasks closed ie: fraps etc... see how it goes.
     
  9. twostepjake

    twostepjake TS Rookie Topic Starter

    Today hasnt been too bad but idk why my internet would **** for 3 days then be ok. its never done that. I havent tried to run the games with anything else running since it started happening and it was still awful which is why I was growing concerned. I honestly dont know about my room and all that. I read that the program used is not too awfully accurate on quadcore cpu's so it could be that.
     
  10. Gunner87

    Gunner87 TS Member Posts: 29

    I recommend using RealTemp. It's one of the better ones out there and you can easily check your cpu and gpu temps all the time.
    http://www.techpowerup.com/realtemp/

    Bad internet connection ie: high ping can also be a factor.

    Hope it gets solved for you. :)
     
  11. JC713

    JC713 TS Evangelist Posts: 6,977   +908

    First off, try clean installing the latest drivers: http://www.geforce.com/drivers/results/59641 <--For Win7/Win8 64bit.
    During the installation, chose custom install and check the option to "Clean Install".

    As for Gunner87s idea of defragmenting, that wont help really. If clean installing the drivers does not work, then run an internet speedtest here: http://speedtest.net/. After that test is complete, press "Share this result" and paste the URL here.
     
     
  12. twostepjake

    twostepjake TS Rookie Topic Starter

    Gunner I tried using realtemp and it said it isnt compatible with quadcore cpu's. Ill give that a shot jc. I did the speed test and everything was quick and easy. after talking with support on smite they had me run a test and said that there were huge spikes when theyre servers were trying to connect to my internet. ive also had the ethernet cord im currently using for probably 10+ years would that have any effect?
     
  13. JC713

    JC713 TS Evangelist Posts: 6,977   +908

    That is odd, realtemp should work with Quad cores. Make sure you download it from here: http://www.techpowerup.com/downloads/2089/Real_Temp_3.70.html.
    Well, ethernet revisions have provided very little improvement over the years. Can you go to device manager and tell me what your ethernet controller is (all that are listed under Network Adapters)? Let us try updating that driver. Also, what router do you have? Because upgrading the network cable will be of no use if you do not have a good router. Final question: What is your ISP (Internet service provider) and what are you Ping, Download, and upload speeds from your results from Speedtest.net.
     
  14. twostepjake

    twostepjake TS Rookie Topic Starter

    Thats exactly where I downloaded it from and it just said its not compatible with my cpu

    Realtek PCIe GBE Family Controller
    I cant remember what router I have but I know that we just bought a new router right before christmas. ISP is comcast.
    Ping-72ms Download-19.02mbps Upload-10.03 mbps
     
  15. JC713

    JC713 TS Evangelist Posts: 6,977   +908

    I dont know where to get drivers for Realtek Ethernet controllers from. Usually, on Intel platforms, it is easy to get a driver, but not for AMD. Your ISP, and download/upload speeds are most likely not the issue. I would find out the Routers IP address and update its firmware. If that doesnt work, I would call Comcast. My friends say that ever since they switched to Comcast, they have gotten increased lag. If you arent in a contract, I would leave Comcast since their internet is notorious for causing in-game lag.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.