TechSpot

Lag

By slate
Jun 3, 2007
Topic Status:
Not open for further replies.
  1. Alright this is my first thread/post and couldn't figure out quite were to put this one. I'm currently playing Neverwinter Nights 2 and im getting tons of lag. I've played World of Warcraft with no issues and was wondering if you could give me some ideas. Not sure on all the info you need so heres some.

    7.56 gb free space.
    BCM v.92 56k modem.
    512 MB of RAM

    I can give other info if you need it.
  2. mopar man

    mopar man TechSpot Ambassador Posts: 1,492

    Hello slate, and Welcome to Techspot!

    You should give us any information you can give us, including graphics card, etc.

    Have you updated your drivers? If not, do so, then come back and let us know if its still doing this.
  3. slate

    slate TS Rookie Topic Starter

    Sorry but im not just to great with computers (which is why i came to you guys for help ^^) i got to my device manager page and i can get to the option of "update driver" im just not sure which drivers to update.
  4. mopar man

    mopar man TechSpot Ambassador Posts: 1,492

  5. slate

    slate TS Rookie Topic Starter

    I updated the driver and sure enough it downloaded a new update. I've got to wake up early so im gonna sleep but ill check after i get home from work to see if that fixed it.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.