TechSpot

Laggy video

By UndeniablyRexer
Dec 11, 2008
  1. Built a PC from components off newegg. Video lagged while doing anything, increased with stress on the system. After two weeks it doesn't boot, and later I find out the HD crashed coincidence?. Take it to a store for diagnostics and they sell me a new PSU and tell me the Graphics card is shot. RMA the graphics card, still waiting on that, reinstall XP and the lagginess continues.
    The diagnostic guy also said that the graphics card was not getting enough power when it was running.

    I find it hard to believe that all 3 things: PSU not enough power, graphics card failing, HD crashing are all just a coincidence. Is it possible that the system was sucking too much power for the PSU to give and as a result some of the components fried?

    Mobo: newegg.com/Product/Product.aspx?Item=N82E16813128352
    Graphics: newegg.com/Product/Product.aspx?Item=N82E16814161236
    500w PSU from this case: newegg.com/Product/Product.aspx?Item=N82E16811156098

    Thanks for your help.
     
  2. nickc

    nickc TechSpot Paladin Posts: 1,674

    a psu from a case is never good, get a good psu. it is the heart of the computer. and yes a bad psu could have caused all of u're problems.
     
  3. UndeniablyRexer

    UndeniablyRexer TS Rookie Topic Starter

    Would a bad PSU cause permanent damage? I put in a better one and the problem continues.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.