TechSpot

Laptop connected to TV w/ HDMI, sound only comes from laptop

By Meg Fleming
Apr 1, 2014
Post New Reply
  1. I connected my laptop to a TV and the sound and video came out perfectly through the TV. Unfortunately that TV had to be given up so I'm using a different TV (Sanyo 52"). The video comes out fine (other than the fact that the screen runs off vertically), but the sound only comes out of my laptop. I tried going to sound and selecting the TV, but the only option is the laptop speakers. I also tried right clicking and showing disabled devices, didn't see the TV nor HDMI. Any ideas? need help ASAP
  2. reysanglenn

    reysanglenn TS Rookie Posts: 16

    Have you tried to set it in the sounds setting? My college ussually did that before we watch something from laptop in TV..
  3. jobeard

    jobeard TS Ambassador Posts: 13,408   +314

    I have the same issue. CP->Sounds also has Headphones, but that's the small plugin next to the mic input, not HDMI. Looks to me that the onboard chip doesn't properly support HDMI :sigh:
  4. jobeard

    jobeard TS Ambassador Posts: 13,408   +314

    Here's what I found ---

    Attached Files:

  5. Meg Fleming

    Meg Fleming TS Rookie Topic Starter

    Like I said I tried that but the TV nor HDMI comes up in sound settings
  6. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,468   +622

    The only way to do it is: Sound > Playback Settings > Select the HDMI device.

    You should have speakers, headphones, and HDMI device.

    If it's not working, install your graphics and sound drivers again. Check graphics drivers to see if audio is not disabled.
  7. jobeard

    jobeard TS Ambassador Posts: 13,408   +314

    "should have speakers, headphones, and HDMI device"
    and I don't have the hdmi - - time for a new/updated driver :)
  8. jobeard

    jobeard TS Ambassador Posts: 13,408   +314

    [SOLVED]

    *First, laptop is Dell Inspiron n5040 and the bios was A03
    Download the A05 update from Dell and run it (performs immediate flashing to A05) and it auto reboots.

    *Second, power off the computer. Attach TV (or other device) via HDMI and make the device access the specific HDMI{1,2,3,4} port you've connected to the computer.

    *Now boot the PC and go to DUAL monitor mode,
    use the CP->Sounds and select the HDMI device and make it the default
    (on a dell it show some Intel device, not hdmi, but it follows the Speakers & Headset we all see).

    Sound moved to the tv (I was using iTunes to test).

    Best wishes.
    St1ckM4n likes this.
  9. jobeard

    jobeard TS Ambassador Posts: 13,408   +314

    @Meg Fleming did my solution provide any help for you?


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.