Laptop Lag Error

By mephisto_007
Jan 22, 2009
Topic Status:
Not open for further replies.
  1. I've notice a slow down sometime lag in performance with my laptop even though it's was just browsing website, one morning I left my laptop idle and came back to see it's crashes and I did a reset by pressing its power button. There this funny looking vertical kind of blocks on my screen although the system did pass the POST but never get back to window (only if I choose safe mode) I think I've might have damage my video card? since the CPU fan did not spin regularly (sometime spin for a short time and then suddenly stop)

    My real problem is I can't get back to window, I think it's no point even if I were to reformat the system. I don't know what to do weather to get a new card or CPU fan or even the board itself. Please guyz help me out?
  2. CCT

    CCT Newcomer, in training Posts: 3,556

    Uninstall your graphics drivers in Safe Mode through Add/Remove Programs.

    Reboot to Normal OS and report if you can do that.
  3. seanc

    seanc Newcomer, in training Posts: 284

    If drivers don't fix it, you'll probably need a new motherboard for your laptop (assuming it's the one in your signature)
  4. mephisto_007

    mephisto_007 Newcomer, in training Topic Starter Posts: 304

    I've uninstall the graphics drivers and reboot to normal OS but it's happen again if I try to reinstall the driver back... is that' mean I have to replace the MB as Seanc mention? oh no please no...
  5. CCT

    CCT Newcomer, in training Posts: 3,556

Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.