Laptop suddenly stops connecting to the Internet

  1. My Toshiba L505D developed an issue over night. It no longer connects to the internet. When I look at the Windows7 network it shows connection to the router but not the internet. The device manager says it is operating, the mfr’s software says the switch is on (and the panel light is on) and that there are no issues. I downloaded and installed the mfr’s driver (2010 is the latest). I’ve pulled the battery and held the button for 60 seconds. All to no connection. Everything points to an issue with the AT&T Uverse router except my cabled desktop and Dell laptop wireless computer access the internet fine. Which points to the Toshiba being the problem. When I pull up the AT&T trouble shooting program it shows the computer as a device but doesn’t have an I/P address, the desktop and Dell laptop have addresses. Any suggestions?
  2. terry5880

    terry5880 TechSpot Enthusiast Posts: 527

    I would go to start type cmd then in there ipconfig/release then ipconfig /renew see if that helps

    apart from this you could try to restore to an earlier time to when it was working those would be the things I would try but someone with more experience should help soon .. im not a technician etc I just like to try help if I got an idea
  3. John Schroeder

    John Schroeder Newcomer, in training Topic Starter

    I tried the ipconfig /renew route, no change. I also hardwired from the laptop to the router, no change. I did find a detail in the ATT trouble shooting program and it shows the same IP as the adapter info on the laptop even though the display shows no data available. I guess its time to call ATT.
  4. terry5880

    terry5880 TechSpot Enthusiast Posts: 527

    my sound silly what is att ahh is it some sort of router if it is then it could be conflicting with something on that laptop I would say uninstall and reinstall the app or restore to an earlier working time
  5. jobeard

    jobeard TS Ambassador Posts: 13,342   +296

    oops; sounds like there are MANUAL tcp settings rather than using DHCP for TCP+DNS.
    DHCP will assure that no two devices get the same address (unless someone tries to outfox the setup).
  6. John Schroeder

    John Schroeder Newcomer, in training Topic Starter

    Terry - ATT is my service provider. When I called last night the automated response announced that customers with MacAfee virus software cannot connect to the internet and would we like a phone call when the issue is resolved. So that fits my problems. The only computer in the house that can't connect at home or in local WIFI areas has MacAfee installed. So I suppose I need to uninstall or go back to a restore point before last Saturday.
  7. jobeard

    jobeard TS Ambassador Posts: 13,342   +296

    good choice :) reboot and then install Avast!
  8. John Schroeder

    John Schroeder Newcomer, in training Topic Starter

    Restoring the system to an August14 point did the trick, it gets internet access again. I also turned off McAfee auto updates. Turns out that one of my wife's co-workers was going to buy a new computer because her computer stopped internet access this weekend; she also has McAfee software and ATT for her service provider.
  9. terry5880

    terry5880 TechSpot Enthusiast Posts: 527

    I thought so . as thats simular problem a friend had and I restored to earlier date and it sorted the problem glad you are now sorted ..


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.