Laptop won't come on

By pw2much
Oct 27, 2012
Post New Reply
  1. My friend brought his Acer Aspire 7741Z w/Win. 7 64bit to me and said it doesn't turn on! so I took the Laptop plugged in the AC adapter to charge it up. I notice two things: 1) the power button doesn't even light up when pressed to turn on the sysytem and if I remove the ac adapter from the laptop after it is charged the power led goes off meaning that maybe the power adapter is defective. Also the laptop will not turn on even with a full charge, now I'm not even sure that the laptop is even charging completely if I cannot get it to turn on at all. I even tried Acer's website for answers but the warranty is out so I searched through support and saw an article showing how to reset the battery,I tried that and nothing.Does anyone have any idea what could be the cause of the laptop not turning on???? (the power led was red before I charged it and it's now blue indicating that it's charging or charged.) But it just won't power-up?
  2. terry5880

    terry5880 TechSpot Enthusiast Posts: 527

    Did your friend changed or touch anything like has he taken out ram or anything like that then miss seated it if he has not touched nothing at all then I would lean towards bad motherboard which is major problem but lets see what others think on here 1st
  3. St1ckM4n

    St1ckM4n TechSpot Evangelist Posts: 3,384   +607

    Try turning it on with the power cable connected. With and without the battery plugged in.
  4. pw2much

    pw2much TechSpot Enthusiast Topic Starter Posts: 109

    I have not explored that yet will get back to you on that! I've checked that all(memory,harddrive) are properly seated and still nothing when pressing the power button, but the power led is on & blue which is suppose to indicate it's either charged or the ac adapter is in.Also the dvd drive usually would be able to eject when there is power to the laptop! I get nothing from that either.
  5. pw2much

    pw2much TechSpot Enthusiast Topic Starter Posts: 109

    I took the battery out and just left the ac adapter in and the power led went off,put the battery back in and the power led is back on! The power button itself does not even light up or show any indication of working. unsually it will light up when pressed but I get nothing when pressing it!!
  6. St1ckM4n

    St1ckM4n TechSpot Evangelist Posts: 3,384   +607

    Seems to me like a bigger issue - mobo perhaps.
  7. terry5880

    terry5880 TechSpot Enthusiast Posts: 527

    Strange that the blue light coming on but I still with my 1st thought of it being the motherboard...
  8. Pan Wah

    Pan Wah TechSpot Enthusiast Posts: 134   +27

    Agree it sounds like the mobo (particularly the electronics regulating charging), or possibly a flaky battery?
  9. St1ckM4n

    St1ckM4n TechSpot Evangelist Posts: 3,384   +607

    Then it should work with no battery inserted.
  10. Pan Wah

    Pan Wah TechSpot Enthusiast Posts: 134   +27

    Oh good, sorted.:)
  11. pw2much

    pw2much TechSpot Enthusiast Topic Starter Posts: 109

    I'm beginning to believe that it is the Motherboard too.Are There any other test I can do to verify that it isn't anything else?
     
  12. Zoltan Head

    Zoltan Head TechSpot Enthusiast Posts: 268   +27

    I'm inclined to agree, as Pan Wah suggested clearly, that the problem lies with the circuitry regulating the charging process (I suspect a hint of sarcasm when he said "Oh good, sorted!")
    The obvious test is to try the charger & battery on another laptop of the same model (or at least same series), if they're good, it's even more likely to be mobo related.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.