TechSpot

Latitude CPi

By softmaplewi
Feb 11, 2009
  1. I recently acquired a Dell CPi. It worked well for a couple of weeks. One nite I left it plugged in and the next am the power box light was pulsing and the cp was dead. No lights, nothing. Tried almost every thing from taking everything off that could come off to try restart. Just got the new battery for it, the old one didn't hold a charge, and still no lights. Tks for any help. Softy
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Remove the battery and power adapter (ie all power out)
    Turn the laptop over and remove the 6 long keyboard screws
    Turn it back over, and remove the keyboard (note some clips at the top)
    Once the keyboard is out, push down on the daughter board that plugs into the motherboard
    place the keyboard back in
    Plug in the power adapter only (confirm powered at outlet)
    Turn on

    Did it work?
    If not, you may need to continue deeper
    Here's also a good guide to start with: Tutorial: No POST (Power On Self Test)
     
  3. softmaplewi

    softmaplewi TS Rookie Topic Starter

    Dell Latitude CDi -- dead

    Tried all the connections under the keyboard to no avail. I think it could be the CMOS but I don't know where or what it is or how to get at it. Advise Softy
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    I hope you left the battery out, when dispersing the voltage
    Also all the other stuff in the guide (Ram refitting; Harddrive out..)

    You know you may need to actually benchtest the Mobo, ie everything out of the case
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...