TechSpot

Leeching/problems with wireless Belkin router?

By anthonychen725
Oct 18, 2005
Topic Status:
Not open for further replies.
  1. Ok, as the topic suggests, I currently have a 4 port wireless Belkin router and also a 5 port hub. The setup is like this, Cable Modem --rj45--> Belkin Router --rj45--> 5 port hub. There is usually one laptop using the wireless connection while most of the computers are connected to the hub via rj45. Our setup is like this because the modem/router is upstairs and then the hub is in the basement where most of our computers are.

    So the problem is when we're using the router, it lags like hell. I did a test, I connected the hub directly to the cable modem. The expected and normal pings (10-30) came back. I was wondering if we might have a virus over the wireless network, or if someone might be leeching off of our wireless service.

    Basically, I wanted to know if I could get the instructions to listing all the IP's/users connected to the router, especially wireless connections. Secondly, I learned somewhere to clean a network I'd have to connect each infected PC separately to the modem and clean that system of infections, and then connect each clean systems back onto the network. Is that right?

    Much help is appreciated, thanks!
  2. tdeg

    tdeg TS Rookie Posts: 348

    If someone is leaching your connection, they will probably show up in the DHCP table on the router. If they have a static IP then they may not.

    Both my routers show me the mac addresses of machines that have connected to the router.

    I would enable either WEP or WPA-PSK on your router... that should preven others from using your broadband.
  3. naiku

    naiku TS Rookie

    The berklin router has a built in 4port switch? When you are hooked up to the switch that is in the router you are getting worse performance then when you are hooked up to a hub off that switch? O.o;;

    Try reseting the the router to default. like tdeg said setup WEP or WPA on the router for ure wireless and even put the MAC address of the wireless device in the Wireless MAC Filter(most routers have it). That should disable a leech.

    Sounds like something wrong with the built in switch if you are getting better performance on a hub then the switch. Make sure the router's switch is set to full duplex. Not sure if you can change that at all...
    Just reset to router to default and reconfigure wireless.
  4. jobeard

    jobeard TS Ambassador Posts: 13,408   +314

    With the laptop already accessing the net, you need to DISABLE broadcasting the SSID and
    enable the encryption. This will stop almost everyone.

    On my networks, I like to us the MAC to force lan addresses.
    Using the Web access to the router, you can see the ATTACH devices, which gives you the MACs.

    Then going to the LAN IP setup, enter a MAC and give it an IP address and a system name.
    (this has a side benefit of making each system have a predictable address).
    Once all the systems are mapped, just fill up the table!
    Take the last real MAC, COPY it and then modify the last digit so as to
    create unique, cloned mac, eg
    01:02:3f:82:71:11
    01:02:3f:82:71:12
    01:02:3f:82:71:13

    Now your firewall can be more precise in excluding intruders by restricting
    the TRUSTED network to only valid addresses defined by you.
    Instead of:: ALLOW 192.168.1.0 thru 198.116.1.255
    you can set ALLOW 192.168.1.0 thru 192.168.1.10 (or whatever upper address you like)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.