Links, Rocketdock etc doesn't open with Firefox plus other woes

By Tommygunn
May 22, 2009
  1. I've just done a re-install of my Windows XP Pro but when I go to click a webpage link or an icon in Rocketdock, to open as a new page, it opens in Internet Explorer when what I want is Firefox.
    How do I correct this?

    Also, I was having a problem in that when it did open a new page it would open it as a tab not a full new page. I then played with Control Panel/Folder Options/File Types/URL:Hypertext Transfer Protocol & URL:Hypertext Transfer Protocol With Privacy to try and alter it to Firefox but to no effect.

    To compound the issue, and even though I did a restore from prior to the above changes, I now have Rocketdock icons opening in IE but also replacing the same page address and not opening individual new pages.

    To clarify I want all links and icons to open in Firefox and all Rocketdock icons to open in a new Firefox page.

    Any help in clearing this matter up would be appreciated.
  2. bobcat

    bobcat TechSpot Paladin Posts: 688   +67

    To make Firefox 3 your default browser for opening links, proceed as follows:

    Firefox > Tools > Options > General > Advanced

    Near the bottom under System Defaults you’ll see the option: “Always check to see if Firefox is the default browser on startup”

    Click on “Check Now”

    The question will appear: “Firefox is not currently set as your default browser. Would you like to make it your default browser?”

    Click on “Yes” > OK
  3. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    And for tyhe new page/new tab issue:

    Tools> Options> tabs> set which you want page to open in.
    Re-size the page once as you would do in IE. Use left mouse button to hold down corners and drag to fill screen. Don't use Maximize button.

    I've been using Firefox for over 4 years and every once in a while when I launch it, it opens in the smaller size. I just re-size it and go on.
  4. Tommygunn

    Tommygunn TS Booster Topic Starter Posts: 67

    Thanks for the input.
    However, someone else told me a different plan. I did Start/Set Program Access And Defaults/Custom/Firefox.
    After doing this both the normal webpage opening and Rocketdock/links problem were solved.
  5. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    Thanks for the update.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...