Linksys WR54G keeps dropping connection

By cvergari39
Feb 3, 2009
Topic Status:
Not open for further replies.
  1. I've had a linksys WR54G wireless router for almost a year now but have never used it wirelessly. It always worked fine with my wired connection to another PC. We got a Wii for Christmas last year and I decided to hook it up wirelessly through the router. We use Verizon DSL 1.5Mb/sec. It was tricky but I was able to get it connected. Then while using my PC, the internet connection would go up and down and then finally just wouldn't connect at all. I know the cables are fine. I totally reinstalled the router and everything seemed to be working fine. I again tried to connect the Wii through the router. I was able to do so. It worked fine for like a day and now the same thing happened as did before. The connection is no longer working on my PC as well as wirelessly.
  2. brucethetech

    brucethetech TechSpot Enthusiast Posts: 301

    try doing a hard reset on it by using the small pin-hole in the back of the router to reset it back to the default settings. are you able to connect to the router wirelessly but just not get out to the web. or can you not connect to the router at all. also when you say it was tricky to get the wii online, what hurdles did you run into. I ask because this process is usually pretty easy so if there is something you ran to this may be an indicator of what your problem is. there is also always the possibilty that the router is defective.
  3. cvergari39

    cvergari39 Newcomer, in training Topic Starter

    Linksys router dropping web connection

    Well when I say "tricky", I mean I had to enter a lot of different setting the first time. I think though, that the router was set to WEP instead of WPA because the second time after I reinstalled the router, I reset the router to PoPPPe and WPA and all I had to do was enter the encryption key and it worked fine-that is of course until the same thing happened again with the dropped connection. Well I did reset it with the little button at the back and reinstalled it again. I got the Wii working with it again and so far my PC connnection has been good and it's almost benn 24hrs since I reconnected the Wii so keep your fingers crossed.
  4. Mamut0o1

    Mamut0o1 Newcomer, in training Posts: 79

    I've seen that problem; you might have the same issue again; I got a router for gaming. That fixed my problem of PC droppin all the time.

    good luck!
    Mamut
  5. dbock57

    dbock57 Newcomer, in training

    I had trouble with the WR54G for about 6 months doing the same thing but both on wired and wireless units until I downloaded an update for the router from Linksys and then the problem was solved. Hope it helps
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.