Linux on a Server.

By me(who else?)
Jun 9, 2004
Topic Status:
Not open for further replies.
  1. I'm turning my Pentium MMX 233 (running at 263 ;) ) with 64MB of RAM into an FTP and HTTP server. It's going to be running behind a router...:dead: . I need a bt of advice about what software I'll need and what variety of Linux I should se. Sorry , but I'm a noob to this (I seem to be saying that a lot recently...)
  2. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    For HTTP and FTP any Linux distro will do, the server software comes with every flavour. Usually Vsftpd and Apache.

    Don't try to install X on that machine.
  3. me(who else?)

    me(who else?) Newcomer, in training Topic Starter Posts: 433

    Will do... thanks!:D
  4. me(who else?)

    me(who else?) Newcomer, in training Topic Starter Posts: 433

    I've set up VSFTPD on the machine with the default config file, but my laptop running Windows XP can't connect to it. WS_FTP connects on port 21, then returns an error (Connection Failed!). I'm using the IP address that Linux returns when I type ifconfig (the eth0, not the loopback, I'm not that much of a n00b). I'm connecting through a D-Link router. I followed the instructions on their website, but to no avail. Please help me, this is iritating. The laptop is connected Wirelessly, but the server is wired.
  5. Phantasm66

    Phantasm66 Newcomer, in training Posts: 6,504

    the default firewall install may be blocking access to port 21
  6. me(who else?)

    me(who else?) Newcomer, in training Topic Starter Posts: 433

    The firewall on what? I already said that I set the router to allow the connection. MY laptop allows WS_FTP to access the internet.
  7. Phantasm66

    Phantasm66 Newcomer, in training Posts: 6,504

    No I mean there may be a software firewall installed on your linux install by default and it may be blocking attempts to access port 21.
  8. me(who else?)

    me(who else?) Newcomer, in training Topic Starter Posts: 433

    I did a quick search, but when I use the setup command, it doesn't change any settings.
  9. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    You shoul test the FTP server on the local machine: connect from the Linux box via loopback and its own IP.

    Look in /etc/init.d/ for an "iptables" entry to see if you have the default Linux firewall installed (BTW, what distro do you have?).
  10. me(who else?)

    me(who else?) Newcomer, in training Topic Starter Posts: 433

    I fixed the problem, but now I have a new problem. The ftp server connects, but I cannot load the folder( the default folder), nor can I change directories, make new folders, etc. Is there a command I need to se to make the folder accessable?
  11. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    Did you change the default FTP root? If you are running chrooted FTP then you have to copy utilities like ls and cd to the FTP directory to be able to list dirs and such.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.