Logitech G9 causing CPU usage spike/lag in any game

By fixmeplease
May 31, 2010
Topic Status:
Not open for further replies.
  1. I went to PE.exe and figured that it was a svchost.exe and the thread was RPCRT.dll
    So, I figured it was a hardware/driver problem. I updated every driver and then started plugged out any usb connection. The lag stopped. I isolated it and figured it was my G9. It recently started making every game go only 8-12 fps. If I plug it out, the fps goes to normal almost instantly. I try to update its driver(if it has any), but couldn't find it. Instead there's Logitech Setpoint and I installed the new version. I still have the same problem. I did plug it out and connect another mouse and the lag completely goes away.


    I'm not sure if this thread belongs in this topic because I don't really know what exactly is causing this issue
  2. mailpup

    mailpup TS Special Forces Posts: 8,390   +205

    I found the same driver so evidently Setpoint is the correct one. Based on your description and attempts at solving the problem, it looks like the problem is the mouse itself. I think you'll have to replace it.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.