TechSpot

Logitech Revolution MX LAG

By tchiseen
Oct 2, 2007
  1. This mouse is fine, except one thing, it lags like a MOTHER sometimes. Mainly when in games (which usually leads to me being pwnd and screaming like a loon), but it happens on the desktop as well. I've got the receiver no more then 1' from the mouse, on a usb2 powered hub. I've got the stupid SetPoint drivers installed and up to date. I use it with a proper mousepad. I don't have a big freakin' unshielded microwave between the mouse and the reveiver, so I don't think its RF intereference ( I don't have wireless, my mobile is on the other side of the room). My computer isnt' crap I've got an E6600, asus p5b, 2gb patriot ddr, 3x320gb sata2s. I emailed logitech they suggested:

     
  2. mailpup

    mailpup TS Special Forces Posts: 8,485   +233

    USB hub. Could you have too many devices connected so that not enough power is getting to your devices? Or is either the receiver or mouse cable so long that power along that cable is degraded? Just a shot in the dark.
     
  3. tchiseen

    tchiseen TS Rookie Topic Starter Posts: 70

    thank you mailpup.

    I have tried it on a cable with no other devices and also plugged into the usb on the front of my case and the back directly into the motherboard, and it has lagged in all places. the (4 port) hub never has other devices on it.

    I've also tried plugging it into my logitech G11 keyboard, which is <1' from my mouse, but it still lags (g11 is usb1.1 afaik.)

    if anyone else has advice or the same problem, please feel free to add your comments!
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.