Magical RaptorX Bios Issue.

By Plague
Sep 6, 2007
  1. So I have a Sata WD RaptorX150. It had been working fine for months when suddenly I got a disk read error during a defrag in win2k. Lost everything in the process of trying to recover it, luckily I made a backup a few weeks earlier, thought to upgrade for the hell of it and put in xp-pro.

    That's the setting, here's the issue. After the initial read error, the drive no longer detects in BIOS, it comes up as "undetected" but it boots fine without any errors and I've been using it for 2 weeks now.

    Every now and then I get a "The driver detected a controller error on \Device\Harddisk0\D" in my event book, but always when it's idling.

    So the question. Why is it not showing in bios but boots fine, what is the error about and am I doomed?

    Specs are:
    AMD64 3800+
    1 gig ram
    MSI K8T Neo2 motherboard
    AGP 7800 GS video
    Creative X-Fi Sound (go crackling pops!)
    Win2k and Winxp pro.
    Every thing's drivers are updated like they should be.
  2. Plague

    Plague TS Rookie Topic Starter

    I did a complete format since there wasn't anything left to show. My previous recovery attempts involved chkdsk /f and WD lifeguard but neither picked up any files after the read error, I'm guessing the master boot record was obliterated.

    The HD is only 5 months old.

    I did find out I had been double powering it just recently though, I didn't realize the wide SATA cable provided power as well, and used the standard power plug with it, but that's been rectified since.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...