Major problems with Windows XP

By charliednz
May 21, 2007
Topic Status:
Not open for further replies.
  1. Hi, I have recently helped a friend buy a pc second hand (I know, bad idea), and am now having major problems with blue screens of deaths, page fault in non-paged area, lots of really bad stuff. After searching through a fair lot of forums I flicked out some RAM, this has fixed it for the past week. Unfortunately it's beginning to crash again, and I'm reaching the end of my tether in trying to fix the thing, all the while getting angry looks from my friend. I don't know how to pick through minidump files, and was hoping someone could help me with that so have uploaded them.

    His specs:

    Windows XP Pro Service Pack 2
    Gigabyte ga-k8nxp-sli with Gigabyte Dual 6600GT 3D1
    4x256MB Geil DDR SDRAM
    Seagate ST3120026A 120GB IDE
    Samsung TSH552B DVD Writer
    Athlon 64 3200+

    Example of error messages he has recieved:

    0x00000050
    0x0000008E
    0xc0000005

    Any suggestions/help are very welcome.

    Thanks again,
    Charlie
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 2,251


    If its getting like that he aint no friend,

    Regards
  3. charliednz

    charliednz Newcomer, in training Topic Starter

    Haha he's actually not too bad, it's just buying a computer was a big step for him. And it's not really recent anymore, say a couple months of crashing. I think anyone's patience would wear thin.
  4. Eagletech

    Eagletech Newcomer, in training

    Download this

    http://oca.microsoft.com/en/windiag.asp

    All you do is burn it to a CD, reboot your comp and it will check to see if you have a problem with your ram.

    Other wise you might have a corrupted sector on your HD. If you have a XP cd run the repair feature. That some times sorts out the crashing.

    When ever i get this i normaly find that i have a HD problem. So i just replace the HD but thats just me :)
  5. CCT

    CCT Newcomer, in training Posts: 3,556

  6. charliednz

    charliednz Newcomer, in training Topic Starter

    Sorry about replying so late, I have been caught up in exams lately. Everybody solutions were very helpful, I found that one of the sticks of RAM were causing major errors, once I took it out things quitened down again. Then I tried to defragment the hard drive, which caused a major crash, so the hard drive was pretty busted as well. I did a complete reformat on that, and the pc has been running without errors so far, so I think that it is fixed. Thanks everybody for your help, I posted the same first message on techguy.com months ago and have still not reply, whereas people here replied after a few hours.

    Unfortunately, I am now having major problems with my pc, and I am hoping someone here may be able to help. When I startup the computer, it loads fine past POST and everything, but just past the welcome screen it begins to have intermittent freezes, e.g. the mouse stops and hard drive access stops for a few minutes, then starts again, then stops. It repeats this until a few of my startup programs have loaded, then restarts itself. Very annoying. I was wondering if anyone has ever had similar problems, and whether this could be caused by a virus or a hardware fault?
    I can load into safe mode, and at first could access the internet in safe mode with networking, but I can't access it anymore. Whilst I could I did a virus scan with the Kapersky online scanner which found no issues, and I do use Zone Alarm Security Suite which seems to keep out most things. I have cleaned the registry using Registry Mechanic, have used chkdsk /r in Windows Recovery Console, and am performing a defragment at the moment. I tried to use a diagnostic startup from msconfig but this didn't seem to help, I got the same error. Unfortunately no error message comes up before the computer restarts, so I have nothing to search other forums for apart from "Mouse freezing" which doesn't work too well.

    Any help/advice would again be greatly appreciated.

    Thanks,
    Charlie

    Oh, and my specs are:

    Windows XP Pro SP2
    AMD Athlon FX-55
    MSI 7900GT x2 in SLI
    Seagate Barrucada 7200.8 250G x2
    Asus A8N-SLI
    Enermax Noisetaker 600W
    Kingston ValueRAM 2x1G Dual Channel
  7. Tedster

    Tedster Techspot old timer..... Posts: 10,074   +13

    I would replace both sticks of ram, run CCleaner registry repair and go from there. Also test your PSU with a PSU tester and multimeter. Read the PSU guide in the guides forum.
  8. charliednz

    charliednz Newcomer, in training Topic Starter

    Did a memtest on my memory which returned no errors, haven't been able to use CClean on my registry yet or test my PSU. I think it might be my PSU as I've had a SATA cable fail lately. I also found some minidumps which I will attach here which correspond to my recent crashes.
  9. charliednz

    charliednz Newcomer, in training Topic Starter

    I have converted one of the dumps into a debuglog, can anyone decipher what is happening here?

    Opened log file 'c:\debuglog.txt'
    kd> .sympath srv*c:\symbols*http://msdl.microsoft.com/download/symbols
    Symbol search path is: srv*c:\symbols*http://msdl.microsoft.com/download/symbols
    kd> .reload;!analyze -v;r;kv;lmnt;.logclose;q
    Loading Kernel Symbols
    .........................................................................................................................................................
    Loading User Symbols
    Loading unloaded module list
    ..................................................
    Unable to load image nv4_disp.dll, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for nv4_disp.dll
    *** ERROR: Module load completed but symbols could not be loaded for nv4_disp.dll
    ERROR: FindPlugIns 8007007b
    *******************************************************************************
    * *
    * Bugcheck Analysis *
    * *
    *******************************************************************************

    KERNEL_MODE_EXCEPTION_NOT_HANDLED_M (1000008e)
    This is a very common bugcheck. Usually the exception address pinpoints
    the driver/function that caused the problem. Always note this address
    as well as the link date of the driver/image that contains this address.
    Some common problems are exception code 0x80000003. This means a hard
    coded breakpoint or assertion was hit, but this system was booted
    /NODEBUG. This is not supposed to happen as developers should never have
    hardcoded breakpoints in retail code, but ...
    If this happens, make sure a debugger gets connected, and the
    system is booted /DEBUG. This will let us see why this breakpoint is
    happening.
    Arguments:
    Arg1: c0000005, The exception code that was not handled
    Arg2: bfa7dc54, The address that the exception occurred at
    Arg3: b36016d0, Trap Frame
    Arg4: 00000000

    Debugging Details:
    ------------------


    EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at "0x%08lx" referenced memory at "0x%08lx". The memory could not be "%s".

    FAULTING_IP:
    nv4_disp+a8c54
    bfa7dc54 8b5610 mov edx,dword ptr [esi+10h]

    TRAP_FRAME: b36016d0 -- (.trap 0xffffffffb36016d0)
    .trap 0xffffffffb36016d0
    ErrCode = 00000000
    eax=00000001 ebx=004f005e ecx=00000000 edx=00000000 esi=53657661 edi=004f005e
    eip=bfa7dc54 esp=b3601744 ebp=00000001 iopl=0 nv up ei pl nz na po nc
    cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010202
    nv4_disp+0xa8c54:
    bfa7dc54 8b5610 mov edx,dword ptr [esi+10h] ds:0023:53657671=????????
    .trap
    Resetting default scope

    DEFAULT_BUCKET_ID: DRIVER_FAULT

    BUGCHECK_STR: 0x8E

    PROCESS_NAME: msnmsgr.exe

    LAST_CONTROL_TRANSFER: from bf907c09 to bfa7dc54

    STACK_TEXT:
    WARNING: Stack unwind information not available. Following frames may be wrong.
    b36017c0 bf907c09 e261d000 e19cec68 e1af2714 nv4_disp+0xa8c54
    b36017f8 bf9c940b b3601810 b3601864 01b1e430 win32k!WatchdogDdGetAvailDriverMemory+0x3b
    b3601854 8053ca28 0b200001 01b1e448 01b1e430 dxg!DxDdGetAvailDriverMemory+0xbb
    b3601854 7c90eb94 0b200001 01b1e448 01b1e430 nt!KiFastCallEntry+0xf8
    01b1e430 00000000 00000000 00000000 00000000 0x7c90eb94


    STACK_COMMAND: kb

    FOLLOWUP_IP:
    nv4_disp+a8c54
    bfa7dc54 8b5610 mov edx,dword ptr [esi+10h]

    SYMBOL_STACK_INDEX: 0

    SYMBOL_NAME: nv4_disp+a8c54

    FOLLOWUP_NAME: MachineOwner

    MODULE_NAME: nv4_disp

    IMAGE_NAME: nv4_disp.dll

    DEBUG_FLR_IMAGE_TIMESTAMP: 453bdc7a

    FAILURE_BUCKET_ID: 0x8E_nv4_disp+a8c54

    BUCKET_ID: 0x8E_nv4_disp+a8c54

    Followup: MachineOwner
    ---------

    eax=00000001 ebx=004f005e ecx=00000000 edx=00000000 esi=53657661 edi=004f005e
    eip=bfa7dc54 esp=b3601744 ebp=00000001 iopl=0 nv up ei pl nz na po nc
    cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010202
    nv4_disp+0xa8c54:
    bfa7dc54 8b5610 mov edx,dword ptr [esi+10h] ds:0023:53657671=????????
    ChildEBP RetAddr Args to Child
    WARNING: Stack unwind information not available. Following frames may be wrong.

    Update: Just replaced my 2 gigs with a 256MB Geil stick of RAM, and the same problem occurred with the same error message.

    As the RAM was not faulty, tried the driver verifer in windows. Caused IO system verification error in stream.sys, wdm driver error 22e. Uninstalled video card drivers, reinstalled, and it seems to be working perfectly.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.