TechSpot

Marvell controller not recognised by Windows 7

By Hodsocks
Dec 3, 2009
Topic Status:
Not open for further replies.
  1. I have a pc with an ASUS M2V motherboard, there are 2 sata hard drives connected to the VIA raid controller in RAID formation and one SATA drive connected to the Marvell 116121 controller. My problem is that windows is not recognising the Marvell controller or the attached hard drive. When the system boots up it recognises the RAID drives, then recognises the Marvell controller and the attached drive but once it is into windows the Marvel and the drive are not listed.
    I have disabled and then enabled the contoller in the BIOS but without success and can't think what else I can do, have you guys any suggestions?
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Type diskmgmt.msc in the Start Search Box, and press Enter
    Do you see your disk in there?
    If so, you may need to assign a drive letter or format it (if its a new Hard Drive)
     
  3. Hodsocks

    Hodsocks TS Guru Topic Starter Posts: 528

    I tried that but no disc shown in device manager or disk management. The drive is only shown during initial boot up.
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Are all your Asus drivers up to date?
     
  5. Hodsocks

    Hodsocks TS Guru Topic Starter Posts: 528

    As up to date as they can be as the ASUS site only has Vista drivers.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.