Mass Storage Drives not working

By golfing22
Jun 7, 2006
  1. I recently upgraded from Windows XP home to Windows XP Pro. After I upgraded I noticed that none of my mass storage devices would not work in my computer(USB stick, iPod, Memory Card reader). THe devices show up just fine in Device Manager but they never show up in Windows explorer.

    These are the things I've tried to far:
    1.Remove all USB devices from device manager
    2. Repair windows
    3.manually assign a drive letter to the device with Logical Disk manager
    4. Reinstalled motherboard drivers

    If I boot up a cd of Knoppix the USB keys work just fine though

  2. benken2202001

    benken2202001 TS Enthusiast Posts: 114   +16

    delete/uninstall all the drivers that are installed for these devices. Windows pro thinks the drivers are there, so it won't install them, but can't access the existing ones for some reason.
  3. golfing22

    golfing22 TS Rookie Topic Starter Posts: 22

    I just tried unistalling the devices from device manager but it didn't help,

    thanks anyways
  4. benken2202001

    benken2202001 TS Enthusiast Posts: 114   +16

    in windows xp, simply removing the devices doesn't remove the drivers from your system. It simply removes the association of the device to the driver. The driver will remain on your system.
  5. golfing22

    golfing22 TS Rookie Topic Starter Posts: 22

    well then, how do i remove the drivers physically then?

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...