TechSpot

Maxtor Drive Auto-formatted itself.

By titandragon2k
Oct 2, 2005
Topic Status:
Not open for further replies.
  1. Hey all,

    I know that a similar post was created of this problem earlier but I couldn't really find a solution from that post because the guy figured it out himself. My maxtor drive, at the moment is a slave, all of a sudden is being recognized as a RAW drive with 100% free space... I don't think I overloaded it with information because I still had 5gb on it... I have had problems with this drive for a while now... every now and then Windows was not able to see the drive and then when I rebooted, everything would be fine... I want to trash the drive but I have all my really important information on it that I would like to recover... here's what I've tried so far:

    Ontrack Easy Recovery Tool which said no information could be found.

    PartitionMagic 8.0 but could not have the option to undelete... I have no idea why... but then again, I'm also very unfamilar with partitionmagic.

    GetDataBack NFTS took about 4 hours to scan and said that there was no information found on the harddrive...

    Norton Disk Doctor doesn't work and chkdsk said that there are no errors on the drive altho I believe I hear a clicking noise during the scans done by getdataback every now and then...

    So now, I am left with running another couple of programs... When I get home tonight, I will remove it from the desktop and try running it from an external to see if it registers differently...

    Does anybody have any ideas of how I can get my data back besides sending it to a data recovery center??! Any help will be greatly appreciated. Thank you very much!
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.