TechSpot

Mercury pvm7 motherboard problem

By theecoop
Feb 15, 2008
  1. I have downloaded and run all drivers available from mercury-pc.com but nothing is solving device manager multimedia controller in other drivers
    also multimedia video controller ,I have nvida geforce 6200 pci card and drivers loaded with no conflicks on it and realtec ac97 audio fo via and codecs.
    Not sure what mutimedia device is missing drivers? I tried original cd and windows and motherboard site drivers ..... which was hard to find the drivers for model pvm7 because pvm7 pro is the sites top pick...neeed help solving.
    Thanks
     
  2. Matthew

    Matthew TechSpot Staff Posts: 5,268   +92

    Mind taking a screenshot of your Device Manager with the problem area(s) expanded?

    Have you completed all available "Hardware" updates on Windows Update?
     
  3. theecoop

    theecoop TS Rookie Topic Starter

    I did all winxp updates and also directx, and tried updating from motherboard manufacture.
    [​IMG]
     
  4. Matthew

    Matthew TechSpot Staff Posts: 5,268   +92

    Have you installed your chipset drivers?
     
  5. theecoop

    theecoop TS Rookie Topic Starter

    not sure on chipset driver ,will try that and let you know
    also i found a bios update from motherboard manufacturer but they didnt have a flash tool to implement? puzzled on how to now
     
  6. theecoop

    theecoop TS Rookie Topic Starter

    I found issue,thanks everyone for help.. After pc crashed and i did a winxp reinstall I forgot i had and additional card (ATI TV Wonder) still on this pc so loaded drivers and problem solved
     
  7. Matthew

    Matthew TechSpot Staff Posts: 5,268   +92

    Nice :)...
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...