Microphone is picking up output audio that my headset is receiving

By Boblol
Jan 22, 2012
Post New Reply
  1. I have a problem that I hope can be fixed. I just recently bought a new computer and I did not have the same issue on the old computer (which was XP). The one I have now is Windows 7 64 bit home premium. Same headset and everything. Not using a sound card either, just using an integrated one.

    The problem I am having is this: when talking to someone in Skype, my microphone is somehow picking up any output audio that my headset is receiving. For example when I'm playing any game or listening to music and talking to someone, they can hear everything that is happening with crystal clearness. This was not happening on my old computer with the same headset. So I'm guessing it's a Windows 7 thing but I have combed every option and I just don't know what to do. They say it sounds like I'm not even using a headset at all and people tell me to turn off my speakers and put on my headset all the time when this isn't the case!

    It's not because my sound is on max either, if I have the sound at 20% they hear it at the exact same level on top of listening to me talk. I have combed tons of forums and even found another thread with the same issue, but it was outdated from 2 years ago and no fixes for Windows 7.

    I realllly need some help. Any is appreciated.
  2. Buckshot420

    Buckshot420 TechSpot Enthusiast Posts: 467

    Right click the speaker Icon and select playback devices>>>Communications>>>Mute all other sounds
  3. Boblol

    Boblol Newcomer, in training Topic Starter

    That does make it stop, yes. But it mutes everything, so I can't hear the music and/or whatever video game I'm playing as soon as I call someone. Pvping on WoW for example requires that I play with sound and be talking to someone on Skype.

    Nice try though. :(
  4. noztrix

    noztrix Newcomer, in training

    Im reviving this thread since I have the exact same problem.

    I've tried both disabling stereo mix and enabling it but having it muted. None of it worked.
  5. Cinders

    Cinders TechSpot Chancellor Posts: 1,313   +12

    it sounds like your sound driver is to set to "everything you hear" or something like that.
  6. noztrix

    noztrix Newcomer, in training

    Please elaborate.
  7. Cinders

    Cinders TechSpot Chancellor Posts: 1,313   +12

    OK, I don't have an example in front of me right now because I'm remembering a computer setup I had years ago.

    I had a ATI Radeon AIW 9700 Pro video card with a TV turner build into it. I also had a Creative Audigy sound card. To record a TV program with audio I had to set the recording part of the sound driver to "Everything You Hear" or something like that; it's been a LONG time, and I don't remember exactly what the situation was. The TV recording would also have ambient sounds from the room my computer was in unless I unplugged my mic. I suspect you have a similar issue with your sound card, but probably not the same hardware. That's all I remember. You'll have to take a look at the recording part of your sound card driver and see if you have something similar.
  8. freeway

    freeway Newcomer, in training

    same problem driving me nut not being able to listen to music while on team speak

    MSI 970A-G45 AMD 970 Socket AM3+ Motherboard
    on board sound
    turtle beach x12 head set

    it does the same thing with starcraft 2
  9. freeway

    freeway Newcomer, in training

    figured it out for me at least lots of google searching everyone is talking about this stereo mix option im like wtf where is this searching all the WINDOWS options when I should have been looking in realtek device advanced settings
    check the option separate all input jacks as independent input jacks
    [​IMG]
    [​IMG]
  10. EternalNewb

    EternalNewb Newcomer, in training

    I'm having this same issue, but my realtek settings do not look like that. What version are you using?
  11. 0UTL4W

    0UTL4W Newcomer, in training

    Was having the same issues with my Turtle Beach x12 headset, I found a way to fix it on my computer though.

    Right clicked my mixer at the bottom right>recording devices>(my microphone) properties>levels tab> Then disabled the microphone boost by dragging it to 0.0dB

    I'm running on vista btw, hopefully this can help some people out.
     
  12. Buddyweiser

    Buddyweiser Newcomer, in training

    Having the same problem, haven't found any solution I dont know if it's realtek or the bios. Using win XP, tried through volume control to adjust the mic output to default settings, it already is but when I go to master volume>options> properties>recording>Realtek HD Audio input, the recording control, mic, CD and line volume and stereo mix are all ticked and when I go ok none of them is available for change all of them are grey.
  13. Paul Harp

    Paul Harp Newcomer, in training

    I know this is a bit late to the post, but do you have a webcam by chance? You system may have your webcam mic on by default and your system is picking up both mics. I was setting up my X12's to my work PC and everyone said it sounded like I was in a tunnel. Turning off my webcam mic did the trick.
  14. Fect900

    Fect900 Newcomer, in training

    Got it!
    This works for me Thank you!!!!!!
  15. Baboonballs

    Baboonballs Newcomer, in training

    I was having the same problem as well. What fixed it for me was unplugging the USB power cord from my computer and plugging it into an outlet instead. Apparently it was causing feedback on my motherboard which caused the distortion and the sound playing back through my mic.
  16. AlexNielsen2

    AlexNielsen2 Newcomer, in training

    This worked for me

    Attached Files:



Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.