TechSpot

Missing or Corrupt acpi.sys

By Riftpoint
May 9, 2008
  1. I was in the process of troubleshooting another problem, when this cropped up:
    I got a 0x0000098 error, saying that the acpi.sys file is missing.... so now my hard drive won't even boot up. Its a western digital raptor 120gig, and i ran the diagnostic cd on it, got an error on the quick scan, then did the full media scan, and it told me that it had found and fixed the error.
    I'm still getting the acpi.sys error though, and when i use the vista boot cd to try and repair it doesn't recognize that i've got an OS installed, just a blank option box.
    Is there any way to get into the harddrive and fix this??? I would very much like to not loose how everything was setup on the computer, luckily most anything that was important is on my 400gig storage drive...
    Would a live boot cd (like a linux live cd) help? if so, which one and how?
    Thanks!
     
  2. raybay

    raybay TS Evangelist Posts: 10,716   +6

    Bad hard drive. Get a new one. Use this one as a slave to recover your data.
     
  3. Riftpoint

    Riftpoint TS Rookie Topic Starter Posts: 18

    I have an "older" hard drive thats IDE, which still has xp pro installed on it, i tried installing that onto my new system, but i just got a glimpse of boot up and blue screen before it reboots itself, what am i missing for that? my current hard drives are sata, but i've tried it without them hooked up and the hard drive still crashes and reboot immediately.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.