Monitor "no signal" and video cards?

By DLambie
Aug 7, 2012
Post New Reply
  1. Every now and then my monitor looses it's signal "no signal" is only thing on screen however when shut computer down and restart it the monitor is fine.

    Would this be my video card going? or just the drivers?

    I have Geforce 8800 GT (512 mb)

    also I have a
    geforce GT 220 is this one better than the 8800?
  2. cliffordcooley

    cliffordcooley TechSpot Paladin Posts: 5,075   +1,182

    No
    The 220 is less than half the performance value of an 8800. Of the 200 series, you would need a 260 to better a 8800.

    Personally, I'd go for GTX 550Ti or better as they are the newest GPU's and use less power for their performance level.
  3. Zilpha

    Zilpha TechSpot Enthusiast Posts: 349

    Another vote for the 550ti here. I picked one up to use as a backup card while I fight with XFX over replacing my failed 5850, and this little thing is surprisingly capable for a card that cost me around 100 bucks. You might not be able to crank every setting with it, but it's a really great performer for its price point. You can't go wrong, especially if you don't want to spend a ton of money on an upgrade.
  4. DLambie

    DLambie TechSpot Enthusiast Topic Starter Posts: 99

    Thanks for all your replies as my video card the GT 8800 did fail and ended up buying the GTx550 Ti
  5. Cobalt006

    Cobalt006 TechSpot Addict Posts: 1,329   +95

    Good card, I Just Bought EVGA Geforce 550 GT Ti 2 gig superclocked. For my Old computer. Runs great.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.