Monitor won't display anything after pulling out RAM and putting it back in

By hyrumwhite
Jul 3, 2009
Topic Status:
Not open for further replies.
  1. I just got a new computer. It worked just fine. but it only came with 512Mb of RAM. I needed to know what kind it was so i could buy more, so i opened the case, took the proper precautions against ESD, pulled the RAM out to check it, then i put it back in. The monitor now only shows the yellow standby light, and when I turn it on, it says "going to sleep", but the computer seems to start up ok, fans spin and lights come on. I have tried different monitors, a different video card, I've reset CMOS, I changed the input settings on the monitor, nothing has worked. The only thing i can think of is i somehow fried the RAM with ESD or i fried the mobo, despited my precautions. I'm going to buy more RAM to see if that will help. If anyone has any ideas that'd be great cause i'm fresh out.
  2. wolfram

    wolfram TechSpot Paladin Posts: 2,605   +9

    Try putting the RAM on a different slot, and if you can clean the slots with compressed air.
  3. Tedster

    Tedster Techspot old timer..... Posts: 10,067   +13

  4. hyrumwhite

    hyrumwhite Newcomer, in training Topic Starter

    hey, thanks guys, i figured out my problem though. The CMOS battery went bad. I replaced it and I'm good to go. Guess it was just one heck of a coincidence
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.