TechSpot

Monitor won't stay asleep

By Dalton
Aug 23, 2012
Post New Reply
  1. Hi, my monitor doesn't seem to want to stay asleep for very long and it has just started doing this recently. It would go to sleep and wake up for no reason at all. I am on Windows 7 HP. What could cause the monitor to wake by itself all the time? Thanks
     
  2. EXCellR8

    EXCellR8 The Conservative Posts: 2,278

    you can find out if there is a background service waking the screen by opening command prompt and typing:

    powercfg -lastwake and hit ENTER

    for more detailed info do the same thing but instead type:

    powercfg -devicequery wake_armed

    this should lead you to the culprit.
     
  3. Dalton

    Dalton Topic Starter

    Ok when I did powercfg -lastwake it said wake history count 0 and the monitor just woke a little while ago and when I did powercfg -devicequery wake_armed it showed a list of 3 devices: HID Keyboard Device, HID-compliant mouse and NVIDIA nForce Networking Controller. Would this have to do with those devices?
     
  4. EXCellR8

    EXCellR8 The Conservative Posts: 2,278

    Well, unless the keyboard or mouse is moving around on their own I would think the networking controller to be the suspect. There could be a process that uses the device or it could simply be the driver itself. I wouldn't think that remote access or file sharing (if you use these features) would case a monitor to wake or any other display issues though. I've seen instances of some antivirus programs updating and waking displays, so that's a possibility if a slim one. My recommendation is to update the nForce driver and see if that helps.
     
  5. Dalton

    Dalton Topic Starter

    Ok, there is an optional update from MS for the network controller and I can't remember if I updated it with the chipset driver recently or not but I will try that and as for remote access and file sharing, I use file sharing sometimes when sharing between 2 PC's but not lately I haven't. I'm using MSE antivirus and used it for a while now and just noticed this recently. I will update the network controller and see if that helps at all, Thanks for the help!
     
  6. Zoltan Head

    Zoltan Head TS Enthusiast Posts: 268   +27

    It might bear pointing out, I have found issues like this that ARE due to the mouse moving on it's own! This has happened with a couple of optical mouse (presumably if they are parked on the edge between two sampling areas in the sensor field).
    Strange but true ;).
     
  7. Dalton

    Dalton Topic Starter

    It's an optical mouse and I was thinking maybe it's acting up because it's been knocked around a lot and kind of funny how it still works after being banged around so much lol. I forgot to mention that it started doing it when I put the computer on a metal desk with plexiglass top and keyboard drawer top but don't really know if the desk would have anything to do with it, just a thought I guess.
     
  8. EXCellR8

    EXCellR8 The Conservative Posts: 2,278

    Some mice may have trouble with the plexiglass if it's clear. Some manufacturers have implemented a relatively new technology, such as Logitech's "DarkField" feature, which allows the mouse to detect surfaces with translucency. However, since you have the plexi on top of another surface I would think you'd be okay--though you may occasionally see a few little glitches. This only applies if the mouse is right on the clear surface though...
     
  9. Dalton

    Dalton Topic Starter

    Oh ok. Yea I notice the mouse doesn't work real good at all on the plexiglass so I was using some paper as a mouse pad and I moved the mouse away and tried it on a different surface and it still did it. Could it be that the mouse is kinda malfunctioning and causing it to do that?
     
  10. mailpup

    mailpup TS Special Forces Posts: 8,452   +227

    You could try another mouse and see what happens.
     
  11. Dalton

    Dalton Topic Starter

    Ok I will try that. One thing I have noticed recently and figured out exactly what the problem was was that my VGA cable is acting up like if I move it around at the computer end, the display turns greenish and sometimes have to move it around to get it right. I will try and get a cable asap but in the meantime, could that have any affect on the sleep mode?
     
     
  12. mailpup

    mailpup TS Special Forces Posts: 8,452   +227

    Maybe although I don't see a direct connection. I would go ahead and get the new one as you said though.
     
  13. Dalton

    Dalton Topic Starter

    Ok, getting one tomorrow hopefully and still gonna try the mouse thing yet. One thing I did notice today when I had to move the vga cable around to get the display right, the monitor went into sleep mode and also the display is turning other green colors now. After seeing the monitor go into sleep mode when moving the cable it's making me think it really is the cable but still gonna try other things to be sure though.
     
  14. Vrmithrax

    Vrmithrax TechSpot Paladin Posts: 1,286   +232

    Just to throw my thoughts in (a bit late, but oh well)... I've had problems in the past with 2 things. The first was a wireless mouse/keyboard issue. I didn't see whether you specified if the mouse was wireless or not, but I was having constant waking issues and it turned out to be a low battery in the mouse, of all things... Drove me nuts for a while, until I discovered the powercfg trick to see what woke me up.

    The second problem I had (on a different system) was with my network card being set to "wake on LAN" and something in my network or software causing it to kick out of powersave mode. It was the weirdest thing, and to this day I don't know what was pinging or triggering it within my network, but disabling that function on my card stopped the monitor wakeups. Interestingly enough, when I put in a wireless card later and had the "wake on LAN" enabled, it never had the same behavior.
     
  15. Dalton

    Dalton Topic Starter

    It's a wired optical mouse. I use a wireless mouse though but not very often and I got a VGA cable today and tried a different mouse and it still does it. Is wake on LAN in the BIOS? I went to the properties of the ethernet and didn't see it there and was thinking it was in the BIOS but under power management of the nForce ethernet properties, there are 3 boxes and all 3 are checked off and was wondering if these have any affect.

    Allow the computer to turn off this device to save power
    Allow this device to wake the computer
    Only allow a magic packet to wake the computer (never heard of this option before)

    Think I did see the wake on LAN in bios if I remember correctly.
     
  16. Vrmithrax

    Vrmithrax TechSpot Paladin Posts: 1,286   +232

    I believe in that case it was one of the advanced properties in the network connection hardware configuration itself (was a laptop in this case), and it was also in the power management tab for that connection. But I do know that on other desktops I've had there was an option to enable/disable it... In the BIOS power management configuration options I think? Every BIOS tends to be just a little different, and I'm going by very fuzzy memory...
     
  17. Dalton

    Dalton Topic Starter

    Ok I think I found something in the properties of the network connection. Think I have seen it in the BIOS on some motherboards and I don't think it was on this one but if it keeps doing it I will try playing around with that. Thanks for the replies guys!
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.