Motherboard Nvidia 650i ultra problem

By balance17
Aug 31, 2008
  1. It started off when I went on vacation came back and my PC would beep. It was a 6 second beep pause 6 second beep, on and on... The monitor remained blank the mouse didn't work, nor did the keyboard. Everything inside was functioning properly fans/cpu/ect... Once and a while I could get it to work but the monitor would turn off. I then took out the cables/ram sticks and put them back in. The pc would turn on but the error Floppy DIsk (40) error or something would pop up I hit f1 and just moved on the computer would result to crashing. and the beeping would continue if I turned it on. Sometimes it would boot sometimes it wouldn't. The weird part about the floppy is I don't have one. I then completely removed my MOBO. and put it back in. Now The diode that was beeping doesn't work and nor does the monitor/keyboard/mouse... I am thinking the only thing to do now is get a new mobo I already tried a gfx card. I think it's just a crappy mobo but if anyone knows anything lemme know.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    A power surge or power failure while you were on vacation, probably damaged the motherboard. It sounds like the CMOS settings were corrupted, Have you tried resetting the CMOS? From now on, turn off the computer when you are away for more than 24 hours
  3. seanc

    seanc TS Rookie Posts: 88

    Well the constant beeping sounds are consistent with having no memory installed. I'd download the manual for your specific motherboard and make sure you have everything connected properly.

    You had memory installed but the computer was still beeping, so it sounds like your memory may well be faulty, so I'd try replacing it.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...