Multimedia audio controller problem

By silentboy12
Mar 22, 2008
Topic Status:
Not open for further replies.
  1. hey, im new and i don't know what happened but, i restarted my computer and when it started up again, i get a message saying "new device found, multimedia audio controller" i realise i have no sound, and when i check it says no sound device found.
    I try automatic install but it says it cannot find any hardware from the internet, and i dont have a cd for my sound system.

    im a noob at hardware, all i know about my sound is that it is Altec Lansing 221.

    and all i know about my computer specs is that it is
    Microsoft XP media center edition version 2002 with service pack 2 installed
    and that it is a Hewlett Packard Pavillion

    please help me, 1: how to check my computer details, 2: help me get my sound back
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Please click on this link:
    http://www.techspot.com/vb/topic100655.html
    Then click on Start Detection

    This will give you all your drivers (and computer info)
    Select your Audio driver, download and install it.

    If you have further questions, please update your Profile to show what specs you have (Mobo=Hp ????)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.