TechSpot

Multimedia Video Controller missing driver

By shano64
Nov 5, 2010
Post New Reply
  1. I have missing drivers showing in my device manager for Multimedia Video Controller and Multimedia Controller.

    I have reinstalled windows xp on this system maybe 3 or 4 times since I bought it and have never had this problem before. It's a Dell dimension 8200.

    This is the info:

    Multimedia Controller
    PCI\VEN_109E&DEV_0878&SUBSYS_13EB0070&REV_11\4&19FD8D60&0&51F0
    The drivers for this device are not installed.

    Multimedia Video Controller
    PCI\VEN_109E&DEV_036E&SUBSYS_13EB0070&REV_11\4&19FD8D60&0&50F0
    The drivers for this device are not installed.

    Any help would be very much appreciated.
     
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Looks like those devices are part of a TV tuner card you added to your computer.

    Do you remember the make/model? Go the vendor site and look under Support. They should have the drivers for you there. (Or use TV tuner card install CD if yu have it)
     
  3. shano64

    shano64 TS Rookie Topic Starter

    I fixed the issue using drivermax. I just did not realize it had the info online. It was for my tv card. Fixed but now I don't know how to remove this post.
     
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    No need to remove it. The mods will close it.

    Glad its fixed :)
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...