My computer won't load at all

By Hypereon
Jul 15, 2008
Topic Status:
Not open for further replies.
  1. Hi!

    So I thought it'd be a wise idea to clean one of my computers.

    Now when I turn it on, that's all it does is...be on. It doesn't load the BIOS, it won't POST, it doesn't even beep. No error beeps, nothing. The fans run and the LEDs light up but that's all it does.

    I've done absolutely everything I can think of. I've reset the bios RAM, I've stripped the pc down to its bare components, I've applied new thermal paste, tried with a new PSU, taken the Mobo battery out, jumpered it. Everything.

    I'm out of ideas. I've tried every part in another pc that would fit and they're all fine.

    I haven't tried the CPU in another pc as it won't fit. Could this be the problem? If its bust, would the pc still power and fans still run etc?

    If you need specs I can provide them.
  2. THNDR143

    THNDR143 Newcomer, in training Posts: 58

    hmm

    The only thing you didnt do was change the motherboard.
  3. Hypereon

    Hypereon Newcomer, in training Topic Starter

    s'true.

    Are there ways to check if the motherboard is damaged? I see no visible signs of overheating or any damage to it.
  4. nickc

    nickc TechSpot Paladin Posts: 1,623

    please give the specs of the computer especially the MB.
  5. Dr. Vader

    Dr. Vader Newcomer, in training Posts: 118

    Sounds like a bad mobo.

    I'm in the process of RMA for the same problems.

    I thought I was doing something wrong, so I took it to my uncle, and he confirmed it was indeed, a bad mobo.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.