TechSpot

My computer won't load at all

By Hypereon
Jul 15, 2008
  1. Hi!

    So I thought it'd be a wise idea to clean one of my computers.

    Now when I turn it on, that's all it does is...be on. It doesn't load the BIOS, it won't POST, it doesn't even beep. No error beeps, nothing. The fans run and the LEDs light up but that's all it does.

    I've done absolutely everything I can think of. I've reset the bios RAM, I've stripped the pc down to its bare components, I've applied new thermal paste, tried with a new PSU, taken the Mobo battery out, jumpered it. Everything.

    I'm out of ideas. I've tried every part in another pc that would fit and they're all fine.

    I haven't tried the CPU in another pc as it won't fit. Could this be the problem? If its bust, would the pc still power and fans still run etc?

    If you need specs I can provide them.
     
  2. THNDR143

    THNDR143 TS Member Posts: 43

    hmm

    The only thing you didnt do was change the motherboard.
     
  3. Hypereon

    Hypereon TS Rookie Topic Starter

    s'true.

    Are there ways to check if the motherboard is damaged? I see no visible signs of overheating or any damage to it.
     
  4. nickc

    nickc TechSpot Paladin Posts: 923   +11

    please give the specs of the computer especially the MB.
     
  5. Dr. Vader

    Dr. Vader TS Rookie Posts: 98

    Sounds like a bad mobo.

    I'm in the process of RMA for the same problems.

    I thought I was doing something wrong, so I took it to my uncle, and he confirmed it was indeed, a bad mobo.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...