My CPU can't on

By cutesy
Dec 30, 2008
  1. Hi hi. I'm just trying my luck here. (And I'm quite a computer ***** so pardon me for my noobness of computer language). :eek:

    My CPU has no power & was still working fine last night.

    The back of the CPU near the "on-off" button, there is no light. Supposed to have the red light. Is that the battery or what?

    Previously the front of my CPU will have the same problem but it will still work bcos i can hear the fan. I just have to adjust abit the stuff inside to have the light turn red.

    Help man!! No com today marks a SAD begining for 2009. :dead: No more facebooking & dota games.

    Thank you very much!!!

  2. cutesy

    cutesy TS Rookie Topic Starter

    Oh yes. my mouse has lights though. SIGH.
  3. BlkHeartWolf

    BlkHeartWolf TS Rookie Posts: 151

    is this a dell
  4. cutesy

    cutesy TS Rookie Topic Starter

    No it's not. But the parts were put together by my ex bf... If I'm not wrong there is a part that was used from my previous com. The rest were bought 1 yr ago... SIGH. appreciate you replying...
  5. BlkHeartWolf

    BlkHeartWolf TS Rookie Posts: 151

    OK well i don't believe the light should be read do you know what part you jimmied when it goes red?
    Is the light on the motherboard or cpu case
  6. Xolotl

    Xolotl TS Rookie

    Sounds like dead motherboard. What happens when you press the power button? Anything you can hear? (Not from the speakers of course ;p )
  7. cutesy

    cutesy TS Rookie Topic Starter

    Erm... it's the red colour thing in the middle of the cpu. Whenever there's no light (at the H00 in front of the CPU) when i turn on, i try to push here n there to try make it work. Normally there's still some sound or the fan turning.

    Power button: totally no sound.

    I duno which 'thing' is the one I need to change.

    Thank you so much for all your help! Really really appreciate it.
  8. poteljito

    poteljito TS Rookie Posts: 39

    OR! You could like check the cable in the back and make sure it's connected right in the wall outlet and in the PC. And than try to see if the button for the "battery" goes red(it's actually a power supply). Cause the red button on the back should always be "on" even if the PC is turned off since it's only a indicator that the power supply is on. So if that button is not turned on it's not getting the power it needs. Or your ex tried to screw with you muahahah. No really try the cable.
  9. BlkHeartWolf

    BlkHeartWolf TS Rookie Posts: 151

    LET's forget the EX jokes please

    If you heard the fan then it wants to power up.
    if it was just built a year ago it may be worth taking into a place for repairs
    if to have a cell phone or camera and you can take a photo of the motherboard
    MFG model name i can let you know what i think
  10. poteljito

    poteljito TS Rookie Posts: 39

    Oh yeah i had a problem like that once. It fixed itself after short time. You should ask for a new motherboard or a repair if you have the guarantee.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...