TechSpot

My Internet won't load any pages!

By Aspen
May 3, 2012
Post New Reply
  1. I have an HP Pavilion g4, Windows 7. I downloaded AVG anit-virus yesterday and ran scans and all that, and everything was fine, But afterwards, my internet won't load. I have tried FireFox and Internet Explorer. I deleted FireFox in hope that I could reinstall it, but I can't find the download because my internet explorer won't load even Google. It was off and on yesterday with working, but today since I've been on it four hours ago, I have only gotten Google to load once, and then just the main page and it wouldn't load any search pages. I have tried to go through Internet Options, and I clicked reset but then it freezes when it says it is "Applying Default Settings." Please help! That is my only computer and I need it to work!
  2. bobcat

    bobcat TechSpot Paladin Posts: 688   +67

    Did you delete items that AVG found during the scan? If so, you can try to restore them from the quarantine, if they are there.

    The straight approach is to uninstall AVG and do a system restore.

    To proceed from where you are now, or if you still have the problem after the above steps, launch network troubleshooting by right-clicking on the network icon in the notification area of the Windows 7 desktop and selecting Troubleshoot problems. Windows Network Diagnostics will launch and attempt to detect and correct what’s wrong.
  3. Aspen

    Aspen TS Rookie Topic Starter

    V
    I have already restored everything that it deleted. I am uninstalling AG now.
  4. learninmypc

    learninmypc TS Evangelist Posts: 5,226   +232

    After you uninstall AVG, do a system search for it & get rid of everything. Reboot & click on whatever browser you're using & click File on top left of the browser to see if Work Offline is checked. If so,UN check it & see if you can get back online.
  5. bobcat

    bobcat TechSpot Paladin Posts: 688   +67

    Have you also run network troubleshooting? You don't lose anything to try that at this stage.
  6. mike1959

    mike1959 TS Addict Posts: 1,060   +19



Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.