TechSpot

My pc hangs up at shutdown

By jimflint1
Feb 3, 2006
  1. I just reinstalled xp a couple of days ago, so why I'm having this problem I'm not sure. After I click "start", then "turn off computer" and it goes to the blue shutdown screen, I get a message "installing update 1 of 1". That would be fine except apparently it never finishes. The night before last, after a couple of hours of this, I just shut the thing off. Last night, I let it run in that status all night and it was still there this morning when I woke up. Any ideas why this is happening and what I can do about it?
     
  2. Peddant

    Peddant TS Rookie Posts: 1,446

    This is THE site for shutdown issues- http://aumha.org/win5/a/shtdwnxp.php -Look down near the bottom of the page.

    Quote - Click Start, click Run, type SERVICES.MSC, click OK. Stop the Automatic Updates service. Rename the c:\Windows\SoftwareDistribution folder to c:\Windows\SoftwareDistribution.old. Restart the Automatic Updates service. (Tip from MS-MVP Bill Castner.)
     
  3. jimflint1

    jimflint1 TS Enthusiast Topic Starter Posts: 212

    Thanks, I'll give that a try.
     
  4. jimflint1

    jimflint1 TS Enthusiast Topic Starter Posts: 212

    Well I tried, but could not find "automatic updates" in the services.msc menu. So I navigated to where Auto updates is normally found in system, turned them off, and tried to rename SoftwareDistribution. I got an error message that said I couldn't rename this file as it was write-protected. Any suggestions?
     
  5. Peddant

    Peddant TS Rookie Posts: 1,446

    There SHOULD be Automatic updates in the services.msc menu.On my pc it`s the fourth one down.Double click on it,and click stop.Then you can re-name the software distribution folder,then restart the service.The control panel auto updates is not the same thing as the Windows service.If you still have trouble re-naming it you might have to follow the instructions here- http://support.microsoft.com/default.aspx?scid=kb;en-us;308421&sd=tech This is all assuming that the log error IS the cause.
     
  6. jimflint1

    jimflint1 TS Enthusiast Topic Starter Posts: 212

    Yeah, I found it. Then I tried stopping it several times after rebooting each time. I keep getting the same message: Could not stop the Automatic Updates service on Local Computer. Error 1053: The service did not respond to the start or control request in a timely manner.

    Any idea as to why I can't stop it in a timely manner?
     
  7. Peddant

    Peddant TS Rookie Posts: 1,446

    The only thing I can think of is that your not logged in as administrator.Perhaps it`ll work in safe mode ? I`m running out of material.Every shutdown issue there ever was is on that website somewhere.
     
  8. jimflint1

    jimflint1 TS Enthusiast Topic Starter Posts: 212

    Well, thanks for trying. There's something strange going on, and I am logged on as administrator, so that's not it--unless one of my kids logged onto my account and changed those settings, which isn't out of the realm of possibility. I'll have to at least check that. And also, I get the little Microsoft update symbol down on the bottom right, and it stays at right around 3-4% download complete. Will those downloads continue if I'm using Firefox as my browser? I think I'll completely review that webpage you sent me and see if I've missed something that might help. Once again, I appreciate your help.

    Shane
     
  9. Peddant

    Peddant TS Rookie Posts: 1,446

    Auto updates are not browser dependant.Is it trying to download SP2 ? If it is,that would explain the time it`s taking.The shutdown issue is obviously related to auto updates.Keep fiddling until something works.That`s my preferred method.
     
  10. jimflint1

    jimflint1 TS Enthusiast Topic Starter Posts: 212

    If it is, I don't know why--I already have sp2 on my machine. And the downloads I approved looked like patch updates--they all began with a K. There was some information on the 1053 error at Microsoft. Something to do with Microsoft .Net framework 1.1 needing to have an SP1 fix. I tried that, but got an error message when I went to install it--something about not having the program the update was supposed to update. I think I may need to download the entire framework file if I can find it. Then upgrade it if necessary. Anyway, here's the link in case you want to look at it: http://support.microsoft.com/?kbid=839174

    The thing is, I don't want to download any framework file I don't need, so if you happen to know the right one, let me know.
     
  11. Peddant

    Peddant TS Rookie Posts: 1,446

    If you don`t have .NET framework on your computer,then that is unlikely to be the problem.It`s an optional program,not a compulsory one.Something else must be preventing you from stopping the updates service.I found this-

    Error 1053: The service did not respond to the start or control request in a timely fashion.

    When attempting to start a service, you may receive above error. The resolutions are 1) Depending on your system setup, you may try to run the service under Local System or the administrator account. 2) make sure dependencies is running. 3) Make sure the related files have correct permission. For example, if you can't start the Task Schedule service, you may need to check the if the %SystemRoot%\Schedlgu.txt file has the Read-Only attribute. If yes, you may want to assign write permission.
    EDIT :You could also try disconnecting from the internet,before trying to stop it.

    That might or might not help.
     
  12. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    try start /run /msconfig
    stop here and reboot then delete files you need to fix
     
  13. jimflint1

    jimflint1 TS Enthusiast Topic Starter Posts: 212

    That worked! Thanks. To both of you.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...