My Toshiba A200-196 is dying, sort of

By Morthane
Mar 26, 2009
Topic Status:
Not open for further replies.
  1. If anyone can help that would be awesome.

    I have a Toshiba Equium A200-196 laptop, about a year and a half old. Over the past week it has stopped connecting to the internet and the fan has stopped working.

    I'm trying to take the back off to fix the fan but it's harder than I thought (one of the screws won't come out) so is there any way to fix the fan without taking the back off?

    As for connecting to the internet - it will recognise wireless signal and say it's connected, but if I open Internet Explorer or any other program that uses the internet it says 'Cannot connect' or something similar. I have been informed that this is probably due to needing to reinstall some drivers, but I can't find anywhere to download the drivers from, so if anyone has a link or other suggestions that would be much appreciated.

    This is also kind of urgent - I'm going to be flying halfway across the world in one week, and the laptop is fairly vital...

    Thank you anyone who can help.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,459   +135

    You need to take it in for repair...
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.