My VAIO keyboard is crazy

By ce3
Apr 1, 2008
Topic Status:
Not open for further replies.
  1. The keyboard on my laptop has suddenly started typing incorrect characters. For example, if I type in ipconfig it displays 5*c6nf5g so an i comes out as a 5, a p comes out as an *, etc.
    It happened in the middle of working on it. Up tp then it had been fine.
    I've turned it off and back on again, a few times, but it still has the problem.
    Anyone know what it might be?
    Thanks in advance.
  2. Matthew

    Matthew TechSpot Staff Posts: 6,020   +83 Staff Member

    Elaborate on this please...
  3. roland_xp_80

    roland_xp_80 Newcomer, in training

    I belive there is a program to switch keyboard modes, 101 char or 100, If i'm not wrong, there is some types keyboard, and your keyboard has make some changed, you need to rebnd.. correct me if I'm wrong..
  4. ce3

    ce3 Newcomer, in training Topic Starter

    Thank you. i'll try
  5. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Go to Regional and language settings in Control Panel

    Confirm your country is set correctly on first and last tab.

    You can also go to Device Manager (Start -> Run -> devmgmt.msc )
    You can then expand the + sign on keyboard, and click Remove (or un-install)
    Restart you computer, for Windows to automatically re-install the keyboard

    Test again


    @roland_xp_80 the only program that should be used is any (if any) program that came with the keyboard (usually none - unless mulimedia keyboard hot key assigning)
  6. ronnyron99

    ronnyron99 Newcomer, in training Posts: 16

    my friend had that same trouble and what he did was take the keyboard out and re-seat it and then it worked fine.
  7. Dave50

    Dave50 Newcomer, in training

    Try hitting the function key (Blue FN) and the number lock.
    It will switch numbers on and off.
    U=4, I=5, O= 6, p=* , J=1, K=2 L=3, and so on.
    Do not know why this funktion is needed but it is there.
  8. ksiaze

    ksiaze Newcomer, in training

    That's right. I got the same problem so I clicked on Num Lk/Scr Lk tab to unlock this keys.
    I guess it is for num keyboard, but totally useless.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.