Need help getting PC audio to play on HDTV

By phalcon51
May 10, 2011
Post New Reply
  1. I'm trying to set it up so that I can play videos from my PC on my Samsung HDTV. Here are the particulars: I've got a Dell Studio SPX 435T desktop with a Creative Soundblaster X-Fi Titanium sound card and an NVidia GeForce GTX 260 video card, and a Samsung LN46C670M1F 46" LCD HDTV. I'm using a DVI to HDMI adapter at the video card and running the HDMI cable into the HDMI3 plug on the back of the Samsung. I've cloned my desktop to the TV and I'm getting a great picture and the videos play perfectly, so no problems there.

    I'm running a shielded stereo audio cable with 3.5mm plugs on each end and tried plugging it into the 3.5mm jack on the back of the TV labeled "PC/DVI audio in" and I get nothing. I've tried plugging it into the green "front left/front right" jack on the SB X-Fi card, which was driving my desktop speakers with no problem, as well as the 3 other jacks for "Side L/R", "Front Center/Subwoofer" and "Rear L/R" with no output at the TV from any of them. I next tried using a "Y" cable with a 3.5mm stereo jack on one end and two RCA plugs on the other for the TV side. There are a couple of spots on the back of the TV to plug into, one labeled "Audio 1 & 2" with 2 ea. red and white RCA jacks and one labeled "AV In 2" on the side with one each red, white and yellow RCA jacks. In the Control Panel I'm setting the "Creative SB X-Fi" speakers as the default, but I'm still not getting any audio at the TV.

    Am I missing something here? Do I need to configure something else? I checked all the options in the TV's menu and couldn't find anything that seemed to apply other than naming the device on HDMI3 as the DVI PC.

    Any help would be greatly appreciated.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,675   +152

    If the TV has an HDMI input, the video and sound are both handled through that. NO other connection can be live at the same time
  3. phalcon51

    phalcon51 Newcomer, in training Topic Starter

    Is there any work-around to get the audio signal into the HDMI cable, or is there another way I can hook it up?

    I was going to link an image showing my available connections on the TV, but apparently I can't do that till I have at least 5 posts. So, let's try this:

    please copy and past these links to see the

    back panel connections:
    img.photobucket.com/albums/v294/Phalcon51/HDTV/IMG_0003.jpg

    and the side panel connections:
    img.photobucket.com/albums/v294/Phalcon51/HDTV/IMG_0001-1.jpg

    Thanks
  4. jobeard

    jobeard TS Ambassador Posts: 13,279   +280

    this is where the audio gets dropped.

    If you had a video card with HDMI output, then the PCI slot picks-up the audio for you.
    The DVI-HDMI is video only, so you need to drop back to Composite cables
    (Red+White+Yellow(for the video).
  5. nismo91

    nismo91 TechSpot Maniac Posts: 999   +11

    if your GTX260 doesn't come with any HDMI ports, have you checked the SPDIF port is connected to the mobo / x-fi spdif out?

    [​IMG]
    cause some cards need the SPDIF cable in order for the HDMI sound to works thru the DVI adapter.
  6. phalcon51

    phalcon51 Newcomer, in training Topic Starter

    I'm not sure if this is what you're talking about, but I've got a 2-wire (black/red) cable going from the GTX 260 to the motherboard, but I can't see that it's labeled anywhere. Does the SPIDF connection originate on the video card or the sound card? There's also a white 3-pin connector on the front of the sound card, but no cable is connected to it. It also is not labeled as far as I can tell.

    Here's a couple of pictures of the black/red wire going from the GTX 260 to the motherboard:

    Coming from GTX 260:
    img.photobucket.com/albums/v294/Phalcon51/HDTV/IMG_0002-2.jpg

    Going to motherboard:
    img.photobucket.com/albums/v294/Phalcon51/HDTV/IMG_0005.jpg


    Thanks again,

    Gary
  7. Rabbit01

    Rabbit01 TechSpot Booster Posts: 884   +39

  8. nismo91

    nismo91 TechSpot Maniac Posts: 999   +11

    alright that means by default your HDMI audio is supplied by your onboard sound, not your x-fi.

    perhaps you can try setting your sounds to nVidia HDMI output or onboard digital output as default device instead of the X-Fi and check if the sounds is produced on the TV.
  9. LNCPapa

    LNCPapa TS Special Forces Posts: 4,271   +257

    Any chance you can post a picture of the sound card from the back of the computer? There are several types of X-Fi cards and I'm curious to see if you have a Toslink (SPDIF) output on your card. I've done this before using a DVI-HDMI cable and a toslink cable to pass audio. Based on the images you've posted so far you'd have to plug in the HDMI cable to HDMI 1 on your TV and then there "should" be a setting for HDMI 1 to use an alternative audio source somewhere in your TV menu.

    edit: A better picture of all the inputs available on your TV would provide more helpful info as well
  10. phalcon51

    phalcon51 Newcomer, in training Topic Starter

    Ok, thanks for the link. The red/black cable from the GTX 260 is going to JSP1 on the mobo.

    Does this mean that I should have audio available as output from the video card, even though it's a DVI connection? If so, how do I get it to the TV via the HDMI or some other way?
  11. phalcon51

    phalcon51 Newcomer, in training Topic Starter

    I still can't post images so here's the links:

    SB X-Fi Titanium & GTX 260 backplanes
    img.photobucket.com/albums/v294/Phalcon51/HDTV/IMG_0006-1.jpg

    The rest of the computer connections
    img.photobucket.com/albums/v294/Phalcon51/HDTV/IMG_0005-1.jpg

    Samsung back panel connections
    img.photobucket.com/albums/v294/Phalcon51/HDTV/IMG_0001-3.jpg

    Samsung side panel connections
    img.photobucket.com/albums/v294/Phalcon51/HDTV/IMG_0004.jpg

    I haven't found anything like this in any of the TV menus yet. Could there be a sub-menu that only comes up when it senses an external input?

    Thanks,

    Gary
     
  12. phalcon51

    phalcon51 Newcomer, in training Topic Starter

    Ok, now I can post images. Here are the images listed in the previous post:

    SB X-Fi Titanium & GTX 260 backplanes
    [​IMG]

    The rest of the computer connections
    [​IMG]

    Samsung back panel connections
    [​IMG]

    Samsung side panel connections
    [​IMG]

    Gary
  13. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,711

    It may not be as complicated as it sounds - in order for me to get my laptop (Samsung) to play over the HDMI TV i have to reset the default audio output from the laptop speakers to the external device. All the audio and video signals go through the HDMI connection and there are no others connected.
  14. phalcon51

    phalcon51 Newcomer, in training Topic Starter

    Thanks, but unfortunately I don't have an HDMI output on my computer, just a couple of DVI outputs, the one going to the HDTV with a DVI --> HDMI adapter. I still need to know how to get the audio signal over to the HDTV.

    Gary
  15. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,711

    in that case I think Jobeard has it on the nail. Can you reset your audio output perhaps?
  16. phalcon51

    phalcon51 Newcomer, in training Topic Starter

    Not sure what you mean by resetting the audio output. Are you referring to selecting the playback device in Control Panel?

    [​IMG]

    My only choices are SPIDF Out and HDMI. I have SPIDF Out on the computer, but no SPIDF In on the HDTV and I have HDMI In on the HDTV but no HDMI Out on the computer, other than the DVI --> HDMI adapter that I'm currently using, but everyone's telling me that the HDMI from the DVI output doesn't carry the audio signal. Am I missing something here?

    Also, Jobeard suggested that I use composite cables. I have composite inputs on the TV, but still nowhere to pick up the audio from the computer.

    Gary
  17. Rabbit01

    Rabbit01 TechSpot Booster Posts: 884   +39

  18. nismo91

    nismo91 TechSpot Maniac Posts: 999   +11

    yes it means you can get audio through DVI. your GTX260 is hooked up into JSP1, which is onboard SPDIF.

    i think i found out what's your problem is: you disabled your onboard sound that's why the SPDIF audio from JSP1 - your GTX260 is missing. this is probably because your X-Fi is shipped with your desktop. Even in the bios there is this option:

    HD Audio Controller: Enabled, Disabled, or HDMI only (Enabled by default)

    which means your onboard supports audio routing to GTX260 and it is the one doing it, not the x-fi.

    [​IMG]

    in this page your onboard digital sound should appear and should be set to default (i.e. Intel HD Audio Digital Output)
     
  19. phalcon51

    phalcon51 Newcomer, in training Topic Starter

    Thanks for the info everyone!

    Rabbit01 - I've updated my Nvidia driver to the latest WHQL release. Thanks for the link.

    nismo91 - I'm having a problem right now with my Dell desktop where it doesn't display the POST screen at startup so I can't access the BIOS screen to change anything. They're sending a tech out this week to replace my mobo. Once that's done I'll try your suggestion. Thanks!

    Gary
  20. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,675   +152

    You may be able to have the Dell tech sort this out for you while he's there
  21. phalcon51

    phalcon51 Newcomer, in training Topic Starter

    Hey, good idea - I'll ask him. Thanks.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.