TechSpot

Need help getting the network drivers

By Terryg
Aug 11, 2009
Topic Status:
Not open for further replies.
  1. i just rebuilt a pc from scratch and im missing some drivers. i believe they are nvidia drivers but i dont know which ones they are the only info i got is from device manager which is below. i can not get onto the net until some of these drivers are installed. the computer will not recognize the lan connection

    pci simple communication controller
    multimedia audia controller
    other pci bridge device
    sm bus controller
    video controler

    attached is a print of unknown device identifier
     
  2. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    Before trying to find drivers based on Device IDs, it's best to try and find the drivers based on your motherboards (which has the onboard chips needing drivers you post)

    Can you identify your motherboard?? If you can't identify it just by inspection, you can run Everest Home to identify it (you'll need to install it via removable media)

    To then find your Driver files
    Click for the driver page listed by System Vendor Find your System Vendor, click for their driver support site. Enter your model number, then download your drivers as needed

    Let us know if you still need further help
     
  3. Terryg

    Terryg TS Rookie Topic Starter Posts: 46

    drivers

    will it let me download drivers it to an external media
     
  4. Terryg

    Terryg TS Rookie Topic Starter Posts: 46

    the link for everest is broken
     
  5. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    Hmm.. Thanks for the heads up. I updated the link (so try it again).
    SAVE (not Run or Open) the download file to removable media. Then just transfer the file from media to your problem computer and run it to install
     
  6. Terryg

    Terryg TS Rookie Topic Starter Posts: 46

    ok link worked hopefully this will give me what i need.
     
  7. Terryg

    Terryg TS Rookie Topic Starter Posts: 46

    i got the drivers for the controllers and when i tried to get the drivers for video and audio it failed i thought i copied the everest file but it ended up to be blank
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.