TechSpot

Need Help with very slow Internet

By armen115
Aug 10, 2008
Topic Status:
Not open for further replies.
  1. Hello, I have had the same internet connection for a while, but all of a sudden it has gotten very slow, sometimes not even useable. I have DSL from cogeco and right now videos are unable to load at any time, but browsing the web is very slow but sometimes loads the page. I tried the speed test and have had different results:

    1. Download: 00610
    Upload: 00037
    2. Download: 00001
    Upload: 142
    last test before I posted this:
    Download: 00089
    Upload:140

    Help is very much appreciated
  2. THNDR143

    THNDR143 TS Rookie Posts: 58

    hmm

    reboot the modem.
    check/replace cable between modem and pc.
    Onboard ethernet card? If so, get a PCI ethernet card and try it. (had this same issue twice, and it was caused by the onboard ethernet card dying)
  3. NetCablesPlus

    NetCablesPlus TS Maniac Posts: 480

    As THNDR143 mentioned, reboot all devices involved in this network (modem , router/switch, PC, etc.) My next step would be to call your DSL provider and see if they can find anything that happened on their end to cause this problem. Once you have taken those two steps, you can begin considering other hardware issues (NIC, cabling, etc.)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.