New battery for my Toshiba Satellite A85-S107 doesn't charge

By OklahomaProf
Feb 11, 2011
Post New Reply
  1. I ordered a new, higher capacity battery for my Toshiba laptop (Satellite A85-S107). The original battery was a 14.4V, 2000mAh model and the new battery is a 10.8V, 10400mAh model. The new battery installed fine and the computer worked fine with it but the charge status did not seem to display correctly, showing at first a 22% remaining charge, then upon a restart, showing 74% charge. Connecting the AC adapter did not show the orange charging indicator and the charge status did not change.

    Following some advice on another forum, I restarted the computer in safe mode, let it operate without AC power until the battery discharged (3.5hours) and the computer shut down. I then connected the AC adapter, restarted the computer and this time the charge indicator flashed about once every couple of seconds, the charge status showed 2%. I turned off the computer and let it charge overnight, started the computer in the morning, the charge status was still 2% and the adapter was cool. Upon unplugging the adapter, the computer immediately shut down. How can I get the computer to recognize the new battery so it charges correctly?
  2. CAMusing

    CAMusing TS Enthusiast Posts: 179

  3. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    OklahomaProf, When you ordered the battery did you check that it was going to work with what you already had?

    A newer bigger battery may require a stronger charger. On the battery itself there should be specifications for:
    input of Volts and Amps
    output of Volts and Amps

    as well, there should be the same specifications on your laptop charger.. are you able to post those here?? CAMusing also has posted a toshiba site towards batteries I suggest checking that out as well.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...