TechSpot

New gaming PC wont turn on

By chrisrapp0122
Jul 19, 2008
  1. Hi, i bought all my supplies from tiger direct. I put them all together and when i tried to turn on the pc, the mobo light was blue (and another very small light that was orange) came on, but no response to anything else. I think it might be the power supply but it seems that the mobo is getting power. I tried using the screw driver on the mobo start pins but that didnt do anything.
    maybe its the mobo that came defective but im not sure.
    does anyone have any suggestions?

    heres what i have in my pc

    hard drive- WD Caviar 250GB SATA-3G HD 7200/16MB/SATA-3G

    motherboard-XFX nForce 780i 3-Way SLI Motherboard - NVIDIA nForce 780i, Socket 775

    CPU-Intel Core 2 Quad Q6600 Processor

    power supply-PowerUp GEN-6803 800-Watt Power Supply - SLI-Ready

    RAM-Corsair Dual Channel XMS2 4096MB PC8500 DDR2 1066MHz Memory (2 x 2048MB)

    Video Card-XFX GeForce 9800 GTX

    Standard DVD burner

    Apevia Black/Black X-Plorer ATX Mid-Tower Case

    and a zalman heat sink for the cpu and artic silver thermal grease
     
  2. mailpup

    mailpup TS Special Forces Posts: 6,979   +362

    Did you use standoffs for the motherboard? Also, you probably bought the case and power supply as a combo deal but did you happen to read the poor reviews the power supply received at its separate listing? A few DOAs. Just because you get some power from a power supply (a few lights) does not prove it is good.
     
  3. chrisrapp0122

    chrisrapp0122 TS Rookie Topic Starter

    yea your right, i switched out the power supply and now its working. thanks for the advice.
     
  4. haloman

    haloman TS Rookie Posts: 66

    nice post i was havin same problem
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...