TechSpot

New hard drive not being detected in custom build PC

By alexe3831
Nov 14, 2011
Post New Reply
  1. Ok, So I recently completed building my first computer (desktop) and the system POST
    's but when it starts the HDD detection it cant find my brand new samsung HDD. I did initialize it using an external hard drive reader and I am able to read/write using that, but when I install the Hard drive into the computer in question it isnt detected. I tried checking the jumper posistion (master or slave) and also tried using a different cable.


    Any ideas why its not being detected? Thanks in advance for any help.

    ~AngelWarrior15
    (I apoligize but I am having to get used to my new username for another site)
  2. DKRON

    DKRON TS Enthusiast Posts: 559   +11

    can you see it in the bios menu?
  3. alexe3831

    alexe3831 TS Enthusiast Topic Starter Posts: 122

    Reply

    It's showing up in BIOS but when I boot the computer it POST's and then hangs when it gets to detecting IDE MASTER. I left it running for over a day and it never found it.
  4. DKRON

    DKRON TS Enthusiast Posts: 559   +11

    which IDE is it showing up in the bios as? sounds like you just need to plug it into another IDE slot on your MB because its not plugged in as the MASTER which it needs for a boot drive
  5. Rabbit01

    Rabbit01 TS Booster Posts: 897   +39

    If the motherboard has 2 IDE connections, the HDD in question should be plugged into the primary connection & set as master.

    By initialize, you mean you format & set that partition as bootable? Or just format?
  6. alexe3831

    alexe3831 TS Enthusiast Topic Starter Posts: 122

    harddrive

    I formatted it and set it as bootable. The motherboard in question does have 2 IDE connections and I set the HDD as the primary drive using the drives jumpers. Hope this is what you needed for information. Feel free to ask any other questions you like.
  7. tipstir

    tipstir TS Ambassador Posts: 4,658   +82

    Does your system support Cable Select (CS) if it does and the drive does too use that. Helps takes out the guess with IDE HDD. Primary and Slave route might not be 100%. If you have tried everything then try updating the BIOS and MOBO drivers too. If that still doesn't cut the mustard then you have issue with the internals on the HDD or the MOBO IDE controller is DOD or what I call DUFF!
  8. alexe3831

    alexe3831 TS Enthusiast Topic Starter Posts: 122

    I am unsure whether it supports CS, how would I find that out? As for the BIOS and MOBO drivers, as I do not have a functional OS on that PC, I dont know how it would be possible to do so.
  9. wrt54gs7

    wrt54gs7 TS Enthusiast Posts: 131

    If there are two devices connected to the IDE cable, make sure one of them is a master and the other a slave. Make sure the cables are properly plugged.
  10. alexe3831

    alexe3831 TS Enthusiast Topic Starter Posts: 122

    Well, at the present time, I only want one 120 GB hard drive in it, and once I am able to setup windows, possibly add a second 120 GB. Not sure if it makes a difference.
  11. Rabbit01

    Rabbit01 TS Booster Posts: 897   +39

    You're going to install Windows on the Smasung drive? The installation of the OS will take care of and make the drive bootable. You don't need to have a bootable drive in order to install the OS.

    As for cable select, most hard drive will have a a small diagram on the label that tells you how to set the jumper to enable CS. You should see MA or MS for Master, SL or similar for Slave, and CS for Cable Select.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.