New motherboard, no Ethernet recognition

By Skeletine
Jan 8, 2012
Post New Reply
  1. Hey guys.

    I bought ASUS M5A97 970A AM3+ Motherboard the other day, and it's been working swell for a couple weeks. I was using a wireless internet adapter, but now I'm moved back to university where we have Ethernet instead, and my computer doesn't seem to be recognizing anything when I plug in the Ethernet. I've tried all the troubleshooting options in Windows (7), but to no avail. This laptop is plugged into the socket using the same cable, so it's not a problem with the socket or cable.

    Any suggestions? The LAST thing I want to do right now is RMA a motherboard, for obvious reasons.

    Cheers.
  2. Buckshot420

    Buckshot420 TechSpot Enthusiast Posts: 467

    Did you ever install the LAN driver from the MOBO disk?
  3. fimbles

    fimbles TechSpot Evangelist Posts: 1,232   +119

    Go to control panel, system, device manager.

    Does anything in your hardware list have a yellow triangle next to it? Particulary ethernet controllers.

    If so, go to your mobo manufacturers website or mobo disk as buckshot mentioned and install the correct drivers.
  4. Phoenix108

    Phoenix108 Newcomer, in training

    Check if you have enabled " On board LAN" in the BIOS.
  5. ComputerGuy55

    ComputerGuy55 TechSpot Maniac Posts: 530

    I had this issue during school for some reason with Windows 7 and I'm not sure why it did it, but do this:

    Open a command prompt:

    Start > type cmd at the top of the window, right click and Run as Administrator

    With the new window open, type ipconfig

    from here, you will be given your Default Gateway.

    Now, in the bottom right hand corner, right click your network Icon and Open Network and Sharing Center

    In here, you should see your Active Network, on the right hand side, just under Connect or disconnect, select Local Area Connection beside the word "Connection"

    In here, go to Properties, double click Internet Protocol Version 4 (TCP/IPv4)

    From this new window, select Advanced, in here under Default Gateway, select Add Now type in that default gateway IP Address from the command prompt window.

    Hit OK on all the windows to save/close the windows. and click on the red X between Network and Internet in your Network and Sharing Center window. See if it fixes the issue.

    post back if you resolve this issue.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.