New motherboard, won't post anymore

By draven
May 9, 2007
  1. Okay so here's the story,
    a friend came to me with an emachines T2824 desktop which wouldn't power on anymore, after a little diagnosis of the power supply and all peripherals I concluded that the motherboard was shot. So I ordered a new Biostar P4M80 from Newegg, after installing the new mobo and hooking everything up, it posted and booted just fine and I got into safe mode so I shut the system down and proceeded to connect the HDD Led and Power LED to the mobo and finish putting it back together.. Now all the sudden it won't post anymore. Fans are spinning, drives work, but no keyboard lights and no video signal! I've tried swapping in a compatible CPU and PSU, tried booting with just CPU/Ram/HD and still no post, no beeps, nadda. Even tried clearing CMOS, no luck.. Any ideas or did the motherboard just randomly fail? Power was disconnected while I was messing with the LED connections so I know I didn't short anything.
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    so you didn't replace the power supply that caused the problems in the first place? Hmmm...... looks like you shot the new motherboard now too.....
  3. draven

    draven TS Rookie Topic Starter

    Well I tested the power supply on another emachine and it posted fine so I assumed it was okay.. I suppose it's still a possibility though
  4. Shaw23

    Shaw23 TS Enthusiast Posts: 62

    I agree with Ted, the PSU was probably the reason the first board went bad in the first place, the PSU may have appeared to still work but with improper voltages. Then using this same bad PSU on the new board probably blew the new board. I haven't had much experience with e-machines, but what I have got from reading on here is that the PSU in them almost always go bad and takes out other things with it.

    *When you tried the PSU on the other PC did you check the voltages to verify they were correct or did you only verify that it would turn on?
  5. draven

    draven TS Rookie Topic Starter

    No, I didn't check the voltages, just checked to see if it would power on.. guess I know better for next time :p
  6. CCT

    CCT TS Evangelist Posts: 2,653   +6

    You never said whether you disconnected the LED's again?

    That seems to be when it failed.

    Just curious.

  7. draven

    draven TS Rookie Topic Starter

    Yeah, I did disconnect them but no luck.. It's pretty strange it happened right after I messed with them though.
  8. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    just because a power supply turns on, doesn't mean it's good. You need to TEST it with a PSU tester and/or multi-meter.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...