No browser works except IE

By Mirela
Nov 2, 2012
Post New Reply
  1. Hello all,

    I have an annoying problem that prevents me from using my laptop properly.
    First of all, I get this error for every page I try to open in Google Chrome:
    "This webpage is not available

    The webpage at <any url here> might be temporarily down or it may have moved permanently to a new web address.

    Error 137 (net::ERR_NAME_RESOLUTION_FAILED): Unknown error."

    Secondly, no software can connect to the internet to update itself; for example, when I tried to update Malwarebytes, I got this error:
    [​IMG]

    Finally, from time to time I get an error window from BackupManagerTray (I think this has something to do with Acer BackUp) which states: “The TCP/IP protocol is not installed properly”.

    The first thing I did was to check if I actually have an internet connection - by using 'ping google.com' in Command Prompt, I discovered that I did. Afterwards, I tried to open Internet Explorer and surprisingly, browsing worked just fine - yey for me!

    As I had previous problems with malware and viruses, I tried to disinfect my laptop by using the following software: Bitdefender 2011, AVG 2013, Malwarebyes’s Antimalware, Kaspersky Virus Removal Tool (website version) and TDSSKiller. Some of them found several infections which were cleaned, but my problem persisted.

    I figured there must be a problem with my IP/DNS configuration. In Command Prompt, I tried to reset them by using ‘netsh winsock reset’(and similar commands), but with no result. I have also tried ‘sfc /scannow’ but it didn’t find any problems with the system’s integrity.

    I ran out of options and I really don’t know what to do anymore. If anyone experienced this or has an idea about what my cause this problem, please help me!
  2. jobeard

    jobeard TS Ambassador Posts: 13,026   +221

    Ok, let's go thru the TCP settings.
    get a command prompt and enter IPCONFIG /ALL >myTCP.txt
    then open the myTCP.txt file and look/report these values:
    1. Node Type . . . . . . . . . . . . : Hybrid; if it is anything else, we need to fix it
    2. DHCP Enabled. . . . . . . . . . . : Yes
      Autoconfiguration Enabled . . . . : Yes
    3. Default Gateway . . . . . . . . . : 192.168.0.1
      DHCP Server . . . . . . . . . . . : 192.168.0.1
    4. DNS Servers . . . . . . . . . . . : 216.116.96.2
    5. NetBIOS over Tcpip. . . . . . . . : Enabled
    the BOLD items are a must, the blue ones must exist but may be very different
  3. Mirela

    Mirela Newcomer, in training Topic Starter Posts: 48

    Hello Jobeard,

    Thank you for the reply. I have done as instructed and the report seems OK; the bold ones are as described and the blue ones are slightly different. Do you require the values?

    Regards,

    Mirela
  4. jobeard

    jobeard TS Ambassador Posts: 13,026   +221

    NO.
    get the cmd prompt again and run these tests
    1. ping 8.8.8.8
    2. nslookup 8.8.8.8
    3. ping google-public-dns-a.google.com
    1) seeing time values and no timeouts says you have a valid connection to your ISP and you can send receive packets.
    2) that address corresponds to the name in (3) and that's what should be see as the response. This means you can correctly use DNS to map an address to a name
    3) should return the address seen in (2) and says your DNS can map a name into an address (which is needed in every request from every browser).
  5. Mirela

    Mirela Newcomer, in training Topic Starter Posts: 48

    Just did it and it looks OK to me. I have copied the results just in case you need to check them:

    1) C:\Windows\system32>ping 8.8.8.8
    Pinging 8.8.8.8 with 32 bytes of data:
    Reply from 8.8.8.8: bytes=32 time=25ms TTL=47
    Reply from 8.8.8.8: bytes=32 time=24ms TTL=47
    Reply from 8.8.8.8: bytes=32 time=30ms TTL=47
    Reply from 8.8.8.8: bytes=32 time=34ms TTL=47
    Ping statistics for 8.8.8.8:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 24ms, Maximum = 34ms, Average = 28ms

    2) C:\Windows\system32>nslookup 8.8.8.8
    Server: UnKnown
    Address: 192.xxx.x.x
    Name: google-public-dns-a.google.com
    Address: 8.8.8.8

    3)
    C:\Windows\system32>ping google-public-dns-a.google.com
    Pinging google-public-dns-a.google.com [8.8.8.8] with 32 bytes of data:
    Reply from 8.8.8.8: bytes=32 time=27ms TTL=47
    Reply from 8.8.8.8: bytes=32 time=25ms TTL=47
    Reply from 8.8.8.8: bytes=32 time=25ms TTL=47
    Reply from 8.8.8.8: bytes=32 time=25ms TTL=47
    Ping statistics for 8.8.8.8:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 25ms, Maximum = 27ms, Average = 25ms
  6. jobeard

    jobeard TS Ambassador Posts: 13,026   +221

    PERFECT :)

    Than implicates the browser(s) which are failing.

    DISABLE all addons in every browser.
    Empty the Cash of each.

    oops - forgot to also say, under a command prompt
    • ipconfig /flushdns
    • net stop "dns client"
    • net start "dns client"
  7. Mirela

    Mirela Newcomer, in training Topic Starter Posts: 48

    Did everything as instructed. No change though. Other suggestions?
  8. jobeard

    jobeard TS Ambassador Posts: 13,026   +221

    Ok, let's get specific
    get the version of IE and a url that is responding

    repeat that for each browser installed (cite name, version, and results)
  9. jobeard

    jobeard TS Ambassador Posts: 13,026   +221

    Also pls report the anti-virus program and version installed and *IF* you have it active
  10. Mirela

    Mirela Newcomer, in training Topic Starter Posts: 48

    Every website is loading perfectly on IE (v.9.0.8112.16421 64-bit Edition) - techspot.com for example;
    On Google Chrome (Version 22.0.1229.94 m) I get the same error I mentioned in the first post on every URL:
    "The webpage at <any url here> might be temporarily down or it may have moved permanently to a new web address.
    Error 137 (net::ERR_NAME_RESOLUTION_FAILED): Unknown error."
    On Opera (Version 11.61) I get the following error on all websites:
    “Internal communication error
    Check that the address is spelled correctly, or try searching for the site.”
  11. Mirela

    Mirela Newcomer, in training Topic Starter Posts: 48

    I currently have AVG 2013 (2013.0.2740) on my system and it's enabled. However, I cannot update it just like I cannot update anything.
  12. jobeard

    jobeard TS Ambassador Posts: 13,026   +221

    let's focus on this single URL.


    We have proven that your TCP connection to the ISP is just fine - - it's got to be elsewhere.
    Which version of Windows are you running?
    Are you running from an Admin login or a LUA/UAC limited account?

    If you use SERVICES.MSC you can enable Secondary Logon and get two users running at the same time: here's how
    get a command prompt
    • runas /user:administrator cmd
    • <enter the password>
    notice the window title will show something suggesting Admin (os version impacts the display),
    but also the current directory will usually be \windows\system32

    that window will have Admin privileges :)
    enter services.msc

    now STOP the AVG services (any/all)

    From any LUA/UAC account access http://ww.techspot.com in each browser and report back

    btw:
    is this directly from Chrome or are you looking in the Event Viewer?

  13. Mirela

    Mirela Newcomer, in training Topic Starter Posts: 48

    I am running from an Admin login and I always open Command Prompt with admin privileges.
    I opened the services window, tried to stop the AVG service (only one was running) and I couldn’t; the Stop button from the Actions panel was disabled. However, I changed its Start-up type to ‘Disabled’ and restarted the machine. The same errors popped when opening Chrome and Opera, while IE is working fine.
    The error is directly copied from Chrome.
     
  14. Mirela

    Mirela Newcomer, in training Topic Starter Posts: 48

    I am running from an Admin login and I always open Command Prompt with admin privileges.
    I opened the services window, tried to stop the AVG service (only one was running) and I couldn’t; the Stop button from the Actions panel was disabled. However, I changed its Start-up type to ‘Disabled’ and restarted the machine. The same errors popped when opening Chrome and Opera, while IE is working fine.
    The error is directly copied from Chrome.
  15. jobeard

    jobeard TS Ambassador Posts: 13,026   +221

    1) you should NEVER be browsing the Internet using an Admin ID - - use that only to install MS Updates and to install new programs. Using it day-to-day increases the chances of infections (but you've already paid that price).

    2) AVG has a means to Temporarily disable AVG -- use it to disable ALL functions of AVG.

    retry http://www.techspot.com from all browsers.
  16. Mirela

    Mirela Newcomer, in training Topic Starter Posts: 48

    1) I never thought of it until now, but it makes perfect sense. Thank you for the advice, I’ll make sure to change my usual account after I solve this issue.
    2) I have disabled AVG’s protection but I get the same errors when trying to access techspot.com
  17. jobeard

    jobeard TS Ambassador Posts: 13,026   +221

    Can you use IE to download Avast! If so (do that first!!!), I would recommend
    go offline (disconnect from your router)
    • uninstall AVG
    • Install AVAST!
    • reboot
    • reconnect to the router
    retest all
  18. jobeard

    jobeard TS Ambassador Posts: 13,026   +221

    correct.
    The sequence is this:
    • create a new user-login, give it Admin rights
    • THEN change the rights of your current login to LIMITED.
    You do not need to change the current login name,
    especially if you are logging in under ADMINISTRATOR or OWNER.
  19. Mirela

    Mirela Newcomer, in training Topic Starter Posts: 48

    Sorry for the late reply, my internet connection is far from best and it took a while to download the Avast! kit. I did as you told me, checked the browsers but with no result.
  20. jobeard

    jobeard TS Ambassador Posts: 13,026   +221

    Let's pick on Opera;
    • get the tools->Prefs->General
    • ... set homepage to www.google.com
    • click Advanced->Content
    • click Blocked Sites; delete any/all
    • click History->Disk Cache -- Empty Now
    • Cookies->accept ONLY from sites I visit (all others unchecked)
    • Security->Security Protocols -> enable ALL
    • Network->Proxy Servers ->(*) Use manual but EMPTY all inputs
    • Toolsbars-> Toolbar setup -> select standard_toolbar
    • ....-> Menu Setup->Opera Standard
    • ....->{x} dbl-click text to display context menu
    close the Opera browser and relaunch; does it access Google?
  21. Mirela

    Mirela Newcomer, in training Topic Starter Posts: 48

    No luck unfortunately; it won’t work, I’m getting the same error. I’m starting to think it might be a general issue, not just related to browsers, since I cannot update any programs (Avast! for example). Also, Skype does not connect either. Apparently only IE can connect to the internet. Could this be a particular malware/virus? It all happened all of a sudden and I didn’t change any internet settings recently.
  22. jobeard

    jobeard TS Ambassador Posts: 13,026   +221

    You may be correct. You have three browsers and IE still works. Let's determine if Opera was corrupted.
    Under Control Panel->Programs, find Opera and start to uninstall it. *IF* you are given a REPAIR option, try that first. Otherwise, do the uninstall, get a fresh copy and then reinstall.
  23. Mirela

    Mirela Newcomer, in training Topic Starter Posts: 48

    I just reinstalled a fresh copy of Opera (same version) and it gives me the same error.
  24. jobeard

    jobeard TS Ambassador Posts: 13,026   +221

    Sorry man - - I'm at the end of my rope - - sure wish I could have solved this for you.
    Look at it this way - - this thread is good documentation.

    Hopefully you have backups of your Documents + Pictures (don't try to recover anything other than those).
  25. Mirela

    Mirela Newcomer, in training Topic Starter Posts: 48

    Thanks for everything Jobeard, I really appreciate it. Have a great weekend!


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.